summarylogtreecommitdiffstats
path: root/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'makefile.patch')
-rw-r--r--makefile.patch6
1 files changed, 5 insertions, 1 deletions
diff --git a/makefile.patch b/makefile.patch
index c60736d50d62..b6408000404a 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,10 +1,14 @@
+diff --git a/Makefile b/Makefile
+index eae8b9b..e431741 100644
--- a/Makefile
+++ b/Makefile
-@@ -35,7 +35,7 @@ distclean:
+@@ -36,8 +36,8 @@ distclean:
install: all
install -D -m 0755 "target/release/$(BIN)" "$(DESTDIR)$(bindir)/$(BIN)"
+- install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(sysconfdir)/dbus-1/interfaces/$(RDD).xml"
- install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(sysconfdir)/dbus-1/system.d/$(BIN).conf"
++ install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(datadir)/dbus-1/interfaces/$(RDD).xml"
+ install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(datadir)/dbus-1/system.d/$(BIN).conf"
install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(sysconfdir)/systemd/system/$(BIN).service"
install -D -m 0644 "data/$(POLICY).policy" $(DESTDIR)$(datadir)/polkit-1/actions/$(POLICY).policy