summarylogtreecommitdiffstats
path: root/makefile
diff options
context:
space:
mode:
Diffstat (limited to 'makefile')
-rw-r--r--makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..84e1ca56602a
--- /dev/null
+++ b/makefile
@@ -0,0 +1,19 @@
+all: clean main lint install
+
+clean:
+ rm -Rf pkg
+ rm -Rf src
+ rm -Rf superpowers
+ rm -Rf superpowers*.zip
+ rm -Rf *superpowers-*.pkg.tar.xz
+
+lint:
+ namcap PKGBUILD
+ namcap *superpowers-*.pkg.tar.xz
+
+main:
+ makepkg
+ mksrcinfo
+
+install:
+ sudo pacman -U *superpowers-*.pkg.tar.xz