summarylogtreecommitdiffstats
path: root/merge-with-testing
diff options
context:
space:
mode:
Diffstat (limited to 'merge-with-testing')
-rw-r--r--merge-with-testing25
1 files changed, 25 insertions, 0 deletions
diff --git a/merge-with-testing b/merge-with-testing
new file mode 100644
index 000000000000..97359c11f010
--- /dev/null
+++ b/merge-with-testing
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+set -e
+
+if git branch|grep -q merge; then
+ git branch -D merge
+fi
+
+if ! git remote|grep -q arch; then
+ echo "Adding 'arch' remote"
+ git remote add arch git://projects.archlinux.org/svntogit/packages.git
+ git remote set-branches arch packages/linux
+fi
+
+git fetch arch
+git checkout -b merge --no-track arch/packages/linux
+FILTER_BRANCH_SQUELCH_WARNING=1 git filter-branch -f --subdirectory-filter trunk/
+grep ^pkgver PKGBUILD
+grep ^pkgrel PKGBUILD
+git checkout master
+
+echo "Automerging configs"
+git checkout merge -- config
+
+echo "All done, you can now do git checkout --patch merge PKGBUILD"