summarylogtreecommitdiffstats
path: root/moveit_ros_perception_boost.patch
diff options
context:
space:
mode:
Diffstat (limited to 'moveit_ros_perception_boost.patch')
-rw-r--r--moveit_ros_perception_boost.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/moveit_ros_perception_boost.patch b/moveit_ros_perception_boost.patch
new file mode 100644
index 000000000000..12c0148282d0
--- /dev/null
+++ b/moveit_ros_perception_boost.patch
@@ -0,0 +1,19 @@
+*** a/CMakeLists.txt 2019-03-19 16:52:44.964645874 +0100
+--- b/CMakeLists.txt 2019-03-19 16:52:26.581383809 +0100
+***************
+*** 9,15 ****
+ set(CMAKE_BUILD_TYPE Release)
+ endif()
+
+! find_package(Boost REQUIRED thread signals)
+
+ if(WITH_OPENGL)
+ find_package(OpenGL REQUIRED)
+--- 9,15 ----
+ set(CMAKE_BUILD_TYPE Release)
+ endif()
+
+! find_package(Boost REQUIRED thread)
+
+ if(WITH_OPENGL)
+ find_package(OpenGL REQUIRED)