summarylogtreecommitdiffstats
path: root/mujoco.patch
diff options
context:
space:
mode:
Diffstat (limited to 'mujoco.patch')
-rw-r--r--mujoco.patch88
1 files changed, 68 insertions, 20 deletions
diff --git a/mujoco.patch b/mujoco.patch
index 5e3e3d2a51f8..0fa34eabe449 100644
--- a/mujoco.patch
+++ b/mujoco.patch
@@ -1,8 +1,16 @@
diff --git a/cmake/MujocoDependencies.cmake b/cmake/MujocoDependencies.cmake
-index d919b6e..68485aa 100644
+index 4c15a91..b5e5925 100644
--- a/cmake/MujocoDependencies.cmake
+++ b/cmake/MujocoDependencies.cmake
-@@ -106,9 +106,9 @@ find_package(Git REQUIRED)
+@@ -79,6 +79,7 @@ set(BUILD_SHARED_LIBS
+ CACHE INTERNAL "Build SHARED libraries"
+ )
+
++find_package(lodepng REQUIRED)
+ if(NOT TARGET lodepng)
+ FetchContent_Declare(
+ lodepng
+@@ -103,9 +104,9 @@ set(QHULL_ENABLE_TESTING OFF)
findorfetch(
USE_SYSTEM_PACKAGE
@@ -14,8 +22,8 @@ index d919b6e..68485aa 100644
LIBRARY_NAME
qhull
GIT_REPO
-@@ -130,18 +130,22 @@ findorfetch(
- "true"
+@@ -116,18 +117,22 @@ findorfetch(
+ qhull
EXCLUDE_FROM_ALL
)
-# MuJoCo includes a file from libqhull_r which is not exported by the qhull include directories.
@@ -45,7 +53,7 @@ index d919b6e..68485aa 100644
PACKAGE_NAME
tinyxml2
LIBRARY_NAME
-@@ -154,12 +158,10 @@ findorfetch(
+@@ -140,12 +145,10 @@ findorfetch(
tinyxml2
EXCLUDE_FROM_ALL
)
@@ -59,7 +67,7 @@ index d919b6e..68485aa 100644
PACKAGE_NAME
tinyobjloader
LIBRARY_NAME
-@@ -177,7 +179,7 @@ set(ENABLE_DOUBLE_PRECISION ON)
+@@ -163,7 +166,7 @@ set(ENABLE_DOUBLE_PRECISION ON)
set(CCD_HIDE_ALL_SYMBOLS ON)
findorfetch(
USE_SYSTEM_PACKAGE
@@ -68,16 +76,27 @@ index d919b6e..68485aa 100644
PACKAGE_NAME
ccd
LIBRARY_NAME
-@@ -190,8 +192,6 @@ findorfetch(
+@@ -176,19 +179,6 @@ findorfetch(
ccd
EXCLUDE_FROM_ALL
)
-target_compile_options(ccd PRIVATE ${MUJOCO_MACOS_COMPILE_OPTIONS})
-target_link_options(ccd PRIVATE ${MUJOCO_MACOS_LINK_OPTIONS})
+-
+-# libCCD has an unconditional `#define _CRT_SECURE_NO_WARNINGS` on Windows.
+-# TODO(stunya): Remove this after https://github.com/danfis/libccd/pull/77 is merged.
+-if(WIN32)
+- if(MSVC)
+- # C4005 is the MSVC equivalent of -Wmacro-redefined.
+- target_compile_options(ccd PRIVATE /wd4005)
+- else()
+- target_compile_options(ccd PRIVATE -Wno-macro-redefined)
+- endif()
+-endif()
- # libCCD has an unconditional `#define _CRT_SECURE_NO_WARNINGS` on Windows.
- # TODO(stunya): Remove this after https://github.com/danfis/libccd/pull/77 is merged.
-@@ -217,7 +217,7 @@ if(MUJOCO_BUILD_TESTS)
+ if(MUJOCO_BUILD_TESTS)
+ set(ABSL_PROPAGATE_CXX_STD ON)
+@@ -203,7 +193,7 @@ if(MUJOCO_BUILD_TESTS)
set(ABSL_BUILD_TESTING OFF)
findorfetch(
USE_SYSTEM_PACKAGE
@@ -86,7 +105,7 @@ index d919b6e..68485aa 100644
PACKAGE_NAME
absl
LIBRARY_NAME
-@@ -244,7 +244,7 @@ if(MUJOCO_BUILD_TESTS)
+@@ -230,7 +220,7 @@ if(MUJOCO_BUILD_TESTS)
findorfetch(
USE_SYSTEM_PACKAGE
@@ -95,7 +114,7 @@ index d919b6e..68485aa 100644
PACKAGE_NAME
GTest
LIBRARY_NAME
-@@ -278,7 +278,7 @@ if(MUJOCO_BUILD_TESTS)
+@@ -264,7 +254,7 @@ if(MUJOCO_BUILD_TESTS)
findorfetch(
USE_SYSTEM_PACKAGE
@@ -104,7 +123,7 @@ index d919b6e..68485aa 100644
PACKAGE_NAME
benchmark
LIBRARY_NAME
-@@ -297,6 +297,9 @@ endif()
+@@ -283,6 +273,9 @@ endif()
if(MUJOCO_TEST_PYTHON_UTIL)
add_compile_definitions(EIGEN_MPL2_ONLY)
@@ -114,8 +133,20 @@ index d919b6e..68485aa 100644
if(NOT TARGET eigen)
# Support new IN_LIST if() operator.
set(CMAKE_POLICY_DEFAULT_CMP0057 NEW)
+diff --git a/cmake/MujocoOptions.cmake b/cmake/MujocoOptions.cmake
+index 998b966..213f422 100644
+--- a/cmake/MujocoOptions.cmake
++++ b/cmake/MujocoOptions.cmake
+@@ -86,7 +86,6 @@ get_mujoco_extra_link_options(EXTRA_LINK_OPTIONS)
+
+ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" OR (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND NOT MSVC))
+ set(EXTRA_COMPILE_OPTIONS
+- -Werror
+ -Wall
+ -Wimplicit-fallthrough
+ -Wunused
diff --git a/sample/cmake/SampleDependencies.cmake b/sample/cmake/SampleDependencies.cmake
-index 3534929..6732055 100644
+index 5e98243..88a7838 100644
--- a/sample/cmake/SampleDependencies.cmake
+++ b/sample/cmake/SampleDependencies.cmake
@@ -26,8 +26,8 @@ option(MUJOCO_SAMPLES_USE_SYSTEM_MUJOCO "Use installed MuJoCo version."
@@ -127,8 +158,8 @@ index 3534929..6732055 100644
+option(MUJOCO_SAMPLES_USE_SYSTEM_MUJOCO "Use installed MuJoCo version." ON)
+option(MUJOCO_SAMPLES_USE_SYSTEM_GLFW "Use installed GLFW version." ON)
- set(MUJOCO_DEP_VERSION_glfw
- 7d5a16ce714f0b5f4efa3262de22e4d948851525 # 3.3.6
+ set(MUJOCO_DEP_VERSION_glfw3
+ 7482de6071d21db77a7236155da44c172a7f6c9e # 3.3.8
@@ -59,7 +59,7 @@ findorfetch(
)
@@ -138,11 +169,28 @@ index 3534929..6732055 100644
)
if(MUJOCO_EXTRAS_STATIC_GLFW)
set(BUILD_SHARED_LIBS_OLD ${BUILD_SHARED_LIBS})
+diff --git a/simulate/CMakeLists.txt b/simulate/CMakeLists.txt
+index 2358ef7..25e50e3 100644
+--- a/simulate/CMakeLists.txt
++++ b/simulate/CMakeLists.txt
+@@ -80,6 +80,7 @@ if(MUJOCO_HARDEN)
+ endif()
+
+ # Fetch lodepng dependency.
++find_package(lodepng REQUIRED)
+ if(NOT TARGET lodepng)
+ FetchContent_Declare(
+ lodepng
diff --git a/simulate/cmake/SimulateDependencies.cmake b/simulate/cmake/SimulateDependencies.cmake
-index 9fba6a2..6404d29 100644
+index fa539c2..eb0b95a 100644
--- a/simulate/cmake/SimulateDependencies.cmake
+++ b/simulate/cmake/SimulateDependencies.cmake
-@@ -26,8 +26,8 @@ option(MUJOCO_SIMULATE_USE_SYSTEM_MUJOCO "Use installed MuJoCo version."
+@@ -22,12 +22,12 @@ else()
+ endif()
+
+ option(MUJOCO_SIMULATE_USE_SYSTEM_MUJOCO "Use installed MuJoCo version."
+- ${DEFAULT_USE_SYSTEM_MUJOCO}
++ ON
)
unset(DEFAULT_USE_SYSTEM_MUJOCO)
@@ -151,8 +199,8 @@ index 9fba6a2..6404d29 100644
+option(MUJOCO_SIMULATE_USE_SYSTEM_MUJOCO "Use installed MuJoCo version." ON)
+option(MUJOCO_SIMULATE_USE_SYSTEM_GLFW "Use installed GLFW version." ON)
- set(MUJOCO_DEP_VERSION_glfw
- 7d5a16ce714f0b5f4efa3262de22e4d948851525 # 3.3.6
+ set(MUJOCO_DEP_VERSION_glfw3
+ 7482de6071d21db77a7236155da44c172a7f6c9e # 3.3.8
@@ -59,7 +59,7 @@ findorfetch(
)