summarylogtreecommitdiffstats
path: root/nethack-qt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'nethack-qt.patch')
-rw-r--r--nethack-qt.patch474
1 files changed, 474 insertions, 0 deletions
diff --git a/nethack-qt.patch b/nethack-qt.patch
new file mode 100644
index 000000000000..2dadf140dca1
--- /dev/null
+++ b/nethack-qt.patch
@@ -0,0 +1,474 @@
+diff -Nur old/nethack-3.4.3/include/config.h nethack-3.4.3/include/config.h
+--- old/nethack-3.4.3/include/config.h 2014-01-11 15:21:06.093528897 -0500
++++ nethack-3.4.3/include/config.h 2014-01-11 15:36:45.103559335 -0500
+@@ -43,8 +43,8 @@
+ * Some combinations make no sense. See the installation document.
+ */
+ #define TTY_GRAPHICS /* good old tty based graphics */
+-/* #define X11_GRAPHICS */ /* X11 interface */
+-/* #define QT_GRAPHICS */ /* Qt interface */
++#define X11_GRAPHICS /* X11 interface */
++#define QT_GRAPHICS /* Qt interface */
+ /* #define GNOME_GRAPHICS */ /* Gnome interface */
+ /* #define MSWIN_GRAPHICS */ /* Windows NT, CE, Graphics */
+
+@@ -169,8 +169,8 @@
+
+ #ifdef UNIX
+ /* path and file name extension for compression program */
+-#define COMPRESS "/usr/bin/compress" /* Lempel-Ziv compression */
+-#define COMPRESS_EXTENSION ".Z" /* compress's extension */
++#define COMPRESS "/usr/bin/gzip" /* Lempel-Ziv compression */
++#define COMPRESS_EXTENSION ".gz" /* compress's extension */
+ /* An example of one alternative you might want to use: */
+ /* #define COMPRESS "/usr/local/bin/gzip" */ /* FSF gzip compression */
+ /* #define COMPRESS_EXTENSION ".gz" */ /* normal gzip extension */
+@@ -185,7 +185,7 @@
+ * a tar-like file, thus making a neater installation. See *conf.h
+ * for detailed configuration.
+ */
+-/* #define DLB */ /* not supported on all platforms */
++#define DLB /* not supported on all platforms */
+
+ /*
+ * Defining INSURANCE slows down level changes, but allows games that
+@@ -204,7 +204,7 @@
+ * otherwise it will be the current directory.
+ */
+ # ifndef HACKDIR
+-# define HACKDIR "/usr/games/lib/nethackdir"
++# define HACKDIR "/var/games/nethack/"
+ # endif
+
+ /*
+diff -Nur old/nethack-3.4.3/include/unixconf.h nethack-3.4.3/include/unixconf.h
+--- old/nethack-3.4.3/include/unixconf.h 2014-01-11 15:21:06.093528897 -0500
++++ nethack-3.4.3/include/unixconf.h 2014-01-11 15:22:02.353530721 -0500
+@@ -37,7 +37,7 @@
+ #define NETWORK /* if running on a networked system */
+ /* e.g. Suns sharing a playground through NFS */
+ /* #define SUNOS4 */ /* SunOS 4.x */
+-/* #define LINUX */ /* Another Unix clone */
++#define LINUX /* Another Unix clone */
+ /* #define CYGWIN32 */ /* Unix on Win32 -- use with case sensitive defines */
+ /* #define GENIX */ /* Yet Another Unix Clone */
+ /* #define HISX */ /* Bull Unix for XPS Machines */
+@@ -132,7 +132,7 @@
+ * "extra output" method is used, but not all systems provide access to
+ * a fine-grained timer.
+ */
+-/* #define TIMED_DELAY */ /* usleep() */
++#define TIMED_DELAY /* usleep() */
+ #endif
+
+ /*
+diff -Nur old/nethack-3.4.3/Makefile nethack-3.4.3/Makefile
+--- old/nethack-3.4.3/Makefile 2014-01-11 15:21:06.086862231 -0500
++++ nethack-3.4.3/Makefile 2014-01-11 16:10:37.840029459 -0500
+@@ -15,17 +15,17 @@
+
+ # make NetHack
+ PREFIX = /usr
+-GAME = nethack
++GAME = nethack-qt
+ # GAME = nethack.prg
+-GAMEUID = games
+-GAMEGRP = bin
++GAMEUID = root
++GAMEGRP = games
+
+ # Permissions - some places use setgid instead of setuid, for instance
+ # See also the option "SECURE" in include/config.h
+-GAMEPERM = 04755
+-FILEPERM = 0644
++GAMEPERM = 02755
++FILEPERM = 0664
+ EXEPERM = 0755
+-DIRPERM = 0755
++DIRPERM = 0775
+
+ # GAMEDIR also appears in config.h as "HACKDIR".
+ # VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
+@@ -35,14 +35,14 @@
+ # therefore there should not be anything in GAMEDIR that you want to keep
+ # (if there is, you'll have to do the installation by hand or modify the
+ # instructions)
+-GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
++GAMEDIR = $(PREFIX)/var/games/$(GAME)
+ VARDIR = $(GAMEDIR)
+-SHELLDIR = $(PREFIX)/games
++SHELLDIR = $(PREFIX)/usr/bin
+
+ # per discussion in Install.X11 and Install.Qt
+-VARDATND =
+-# VARDATND = x11tiles NetHack.ad pet_mark.xbm
+-# VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
++#VARDATND =
++#VARDATND = x11tiles NetHack.ad pet_mark.xbm
++VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
+ # for Atari/Gem
+ # VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
+ # for BeOS
+diff -Nur old/nethack-3.4.3/src/Makefile nethack-3.4.3/src/Makefile
+--- old/nethack-3.4.3/src/Makefile 2014-01-11 15:21:06.086862231 -0500
++++ nethack-3.4.3/src/Makefile 2014-01-11 16:10:46.170029729 -0500
+@@ -91,7 +91,7 @@
+ # LFLAGS = -Ml
+
+ # flags for Atari gcc (3.2.1)
+-# CFLAGS = -O -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ # LFLAGS = -s
+ # flags for Atari gcc (3.3)
+ # CFLAGS = -mshort -O2 -fomit-frame-pointer -I../include
+@@ -115,19 +115,19 @@
+
+ # flags for IRIX 4.0.x using native cc
+ # The include files are __STDC__, but have bugs involving const
+-# CFLAGS = -O -I../include -D__STDC__ -Dconst= -woff 100,293
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include -D__STDC__ -Dconst= -woff 100,293
+ # LFLAGS = -s
+
+ # flags for BSD/OS 2.0
+-# CFLAGS = -O -I../include -I/usr/X11/include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include -I/usr/X11/include
+ # LFLAGS = -L/usr/X11/lib
+
+ # flags for Linux
+ # compile normally
+-# CFLAGS = -O2 -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -fomit-frame-pointer -I../include
+ # LFLAGS = -L/usr/X11R6/lib
+ # OR compile backwards compatible a.out format
+-# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+ # LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
+
+ # flags for BeOS
+@@ -137,7 +137,7 @@
+ #LINK = mwld
+ #LFLAGS = -map nethack.xMAP
+ # on Intel:
+-#CFLAGS = -O -I../include
++#CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ #LINK = gcc
+ #LFLAGS = -Xlinker -soname=_APP_
+
+@@ -151,15 +151,16 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
++CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ LFLAGS =
+
+ # The Qt and Be window systems are written in C++, while the rest of
+ # NetHack is standard C. If using Qt, uncomment the LINK line here to get
+ # the C++ libraries linked in.
+-CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include
++#CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include
++CXXFLAGS = $(CFLAGS) -I. -I/usr/include/qt3
+ CXX=g++
+-#LINK=g++
++LINK=g++
+ # For cross-compiling, eg. with gcc on Linux (see also CC further up):
+ #CXX=arm-linux-g++
+ #LINK=arm-linux-gcc
+@@ -186,7 +187,8 @@
+ # Files for a Qt port
+ #
+ WINQTSRC = ../win/Qt/qt_win.cpp ../win/Qt/qt_clust.cpp ../win/Qt/qttableview.cpp
+-WINQTOBJ = qt_win.o qt_clust.o qttableview.o tile.o
++# WINQTOBJ = qt_win.o qt_clust.o qttableview.o tile.o
++WINQTOBJ = qt_win.o qt_clust.o qttableview.o
+ #
+ # Files for a Gnome port
+ #
+@@ -214,8 +216,8 @@
+
+ #
+ #
+-WINSRC = $(WINTTYSRC)
+-WINOBJ = $(WINTTYOBJ)
++WINSRC = $(WINTTYSRC) $(WINX11SRC) $(WINQTSRC)
++WINOBJ = $(WINTTYOBJ) $(WINX11OBJ) $(WINQTOBJ)
+
+ # on some systems the termcap library is in -ltermcap or -lcurses
+ # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
+@@ -230,18 +232,19 @@
+ # WINTTYLIB = -ltermcap
+ # WINTTYLIB = -lcurses
+ # WINTTYLIB = -lcurses16
+-# WINTTYLIB = -lncurses
+-WINTTYLIB = -ltermlib
++WINTTYLIB = -lncurses
++#WINTTYLIB = -ltermlib
+ #
+ # libraries for X11
+ # If USE_XPM is defined in config.h, you will also need -lXpm here.
+-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
++WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
+ # WINX11LIB = -lXaw -lXmu -lXt -lX11
+ # WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
+ # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
+ #
+ # libraries for Qt
+-WINQTLIB = -L$(QTDIR)/lib -lqt
++# WINQTLIB = -L$(QTDIR)/lib -lqt
++WINQTLIB = -lqt-mt
+ #
+ # libraries for KDE (with Qt)
+ WINKDELIB = -lkdecore -lkdeui -lXext
+@@ -255,7 +258,8 @@
+ # libraries for BeOS
+ WINBELIB = -lbe
+
+-WINLIB = $(WINTTYLIB)
++WINLIB = $(WINTTYLIB) $(WINX11LIB) $(WINQTLIB)
++
+
+ # any other strange libraries your system needs (for Sysunix only -- the more
+ # specialized targets should already be right)
+@@ -285,7 +289,7 @@
+ LIBS =
+
+ # make NetHack
+-GAME = nethack
++GAME = nethack-qt
+ # GAME = nethack.prg
+
+ # if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
+@@ -461,13 +465,13 @@
+
+ # Qt windowport meta-object-compiler output
+ qt_kde0.moc: ../include/qt_kde0.h
+- $(QTDIR)/bin/moc -o qt_kde0.moc ../include/qt_kde0.h
++ /usr/lib/qt3/bin/moc -o qt_kde0.moc ../include/qt_kde0.h
+
+ qt_win.moc: ../include/qt_win.h
+- $(QTDIR)/bin/moc -o qt_win.moc ../include/qt_win.h
++ /usr/lib/qt3/bin/moc -o qt_win.moc ../include/qt_win.h
+
+ qttableview.moc: ../include/qttableview.h
+- $(QTDIR)/bin/moc -o qttableview.moc ../include/qttableview.h
++ /usr/lib/qt3/bin/moc -o qttableview.moc ../include/qttableview.h
+
+ $(MAKEDEFS): ../util/makedefs.c $(CONFIG_H) ../include/permonst.h \
+ ../include/objclass.h ../include/monsym.h \
+diff -Nur old/nethack-3.4.3/sys/unix/Makefile.src nethack-3.4.3/sys/unix/Makefile.src
+--- old/nethack-3.4.3/sys/unix/Makefile.src 2014-01-11 15:21:06.100195564 -0500
++++ nethack-3.4.3/sys/unix/Makefile.src 2014-01-11 16:10:59.080030148 -0500
+@@ -91,7 +91,7 @@
+ # LFLAGS = -Ml
+
+ # flags for Atari gcc (3.2.1)
+-# CFLAGS = -O -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ # LFLAGS = -s
+ # flags for Atari gcc (3.3)
+ # CFLAGS = -mshort -O2 -fomit-frame-pointer -I../include
+@@ -115,19 +115,19 @@
+
+ # flags for IRIX 4.0.x using native cc
+ # The include files are __STDC__, but have bugs involving const
+-# CFLAGS = -O -I../include -D__STDC__ -Dconst= -woff 100,293
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include -D__STDC__ -Dconst= -woff 100,293
+ # LFLAGS = -s
+
+ # flags for BSD/OS 2.0
+-# CFLAGS = -O -I../include -I/usr/X11/include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include -I/usr/X11/include
+ # LFLAGS = -L/usr/X11/lib
+
+ # flags for Linux
+ # compile normally
+-# CFLAGS = -O2 -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -fomit-frame-pointer -I../include
+ # LFLAGS = -L/usr/X11R6/lib
+ # OR compile backwards compatible a.out format
+-# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+ # LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
+
+ # flags for BeOS
+@@ -137,7 +137,7 @@
+ #LINK = mwld
+ #LFLAGS = -map nethack.xMAP
+ # on Intel:
+-#CFLAGS = -O -I../include
++#CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ #LINK = gcc
+ #LFLAGS = -Xlinker -soname=_APP_
+
+@@ -151,15 +151,16 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
++CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ LFLAGS =
+
+ # The Qt and Be window systems are written in C++, while the rest of
+ # NetHack is standard C. If using Qt, uncomment the LINK line here to get
+ # the C++ libraries linked in.
+-CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include
++#CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include
++CXXFLAGS = $(CFLAGS) -I. -I/usr/include/qt3
+ CXX=g++
+-#LINK=g++
++LINK=g++
+ # For cross-compiling, eg. with gcc on Linux (see also CC further up):
+ #CXX=arm-linux-g++
+ #LINK=arm-linux-gcc
+@@ -241,7 +242,7 @@
+ # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
+ #
+ # libraries for Qt
+-WINQTLIB = -L$(QTDIR)/lib -lqt
++WINQTLIB = -lqt-mt
+ #
+ # libraries for KDE (with Qt)
+ WINKDELIB = -lkdecore -lkdeui -lXext
+@@ -461,13 +462,13 @@
+
+ # Qt windowport meta-object-compiler output
+ qt_kde0.moc: ../include/qt_kde0.h
+- $(QTDIR)/bin/moc -o qt_kde0.moc ../include/qt_kde0.h
++ /usr/lib/qt3/bin/moc -o qt_kde0.moc ../include/qt_kde0.h
+
+ qt_win.moc: ../include/qt_win.h
+- $(QTDIR)/bin/moc -o qt_win.moc ../include/qt_win.h
++ /usr/lib/qt3/bin/moc -o qt_win.moc ../include/qt_win.h
+
+ qttableview.moc: ../include/qttableview.h
+- $(QTDIR)/bin/moc -o qttableview.moc ../include/qttableview.h
++ /usr/lib/qt3/bin/moc -o qttableview.moc ../include/qttableview.h
+
+ $(MAKEDEFS): ../util/makedefs.c $(CONFIG_H) ../include/permonst.h \
+ ../include/objclass.h ../include/monsym.h \
+diff -Nur old/nethack-3.4.3/sys/unix/Makefile.utl nethack-3.4.3/sys/unix/Makefile.utl
+--- old/nethack-3.4.3/sys/unix/Makefile.utl 2014-01-11 15:21:06.100195564 -0500
++++ nethack-3.4.3/sys/unix/Makefile.utl 2014-01-11 16:10:59.080030148 -0500
+@@ -44,7 +44,7 @@
+ # LFLAGS = -Ml
+
+ # flags for Atari GCC (3.2.1)
+-# CFLAGS = -O -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ # LFLAGS = -s
+ # flags for Atari GCC (3.3)
+ # CFLAGS = -mshort -O2 -I../include
+@@ -72,10 +72,10 @@
+
+ # flags for Linux
+ # compile normally
+-# CFLAGS = -O2 -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -fomit-frame-pointer -I../include
+ # LFLAGS = -L/usr/X11R6/lib
+ # OR compile backwards compatible a.out format
+-# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+ # LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
+
+ # flags for BeOS using the command line
+@@ -89,7 +89,7 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
++CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ LFLAGS =
+
+ LIBS =
+@@ -399,5 +399,5 @@
+ -rm -f gif2txt txt2ppm tile2x11 tile2img.ttp xpm2img.ttp tilemap
+
+ tileedit: tileedit.cpp $(TEXT_IO)
+- $(QTDIR)/bin/moc -o tileedit.moc tileedit.h
+- $(CC) -o tileedit -I../include -I$(QTDIR)/include -L$(QTDIR)/lib tileedit.cpp $(TEXT_IO) -lqt
++ /usr/lib/qt3/bin/moc -o tileedit.moc tileedit.h
++ $(CC) -o tileedit -I../include -I/usr/include/qt3 tileedit.cpp $(TEXT_IO) -lqt-mt
+diff -Nur old/nethack-3.4.3/util/Makefile nethack-3.4.3/util/Makefile
+--- old/nethack-3.4.3/util/Makefile 2014-01-11 15:21:06.103528898 -0500
++++ nethack-3.4.3/util/Makefile 2014-01-11 16:11:06.753363730 -0500
+@@ -44,7 +44,7 @@
+ # LFLAGS = -Ml
+
+ # flags for Atari GCC (3.2.1)
+-# CFLAGS = -O -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ # LFLAGS = -s
+ # flags for Atari GCC (3.3)
+ # CFLAGS = -mshort -O2 -I../include
+@@ -72,10 +72,10 @@
+
+ # flags for Linux
+ # compile normally
+-# CFLAGS = -O2 -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -fomit-frame-pointer -I../include
+ # LFLAGS = -L/usr/X11R6/lib
+ # OR compile backwards compatible a.out format
+-# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
++# CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+ # LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
+
+ # flags for BeOS using the command line
+@@ -89,7 +89,7 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
++CFLAGS = -D__CORRECT_ISO_CPP_STRINGS_H_PROTO -O -I../include
+ LFLAGS =
+
+ LIBS =
+@@ -399,5 +399,5 @@
+ -rm -f gif2txt txt2ppm tile2x11 tile2img.ttp xpm2img.ttp tilemap
+
+ tileedit: tileedit.cpp $(TEXT_IO)
+- $(QTDIR)/bin/moc -o tileedit.moc tileedit.h
+- $(CC) -o tileedit -I../include -I$(QTDIR)/include -L$(QTDIR)/lib tileedit.cpp $(TEXT_IO) -lqt
++ /usr/lib/qt3/bin/moc -o tileedit.moc tileedit.h
++ $(CC) -o tileedit -I../include -I/usr/include/qt3 tileedit.cpp $(TEXT_IO) -lqt-mt
+diff -Nur old/nethack-3.4.3/win/Qt/tileedit.cpp nethack-3.4.3/win/Qt/tileedit.cpp
+--- old/nethack-3.4.3/win/Qt/tileedit.cpp 2014-01-11 15:21:06.106862231 -0500
++++ nethack-3.4.3/win/Qt/tileedit.cpp 2014-01-11 16:01:29.610011689 -0500
+@@ -8,7 +8,7 @@
+
+ tileedit: tileedit.cpp $(TEXT_IO)
+ moc -o tileedit.moc tileedit.h
+- $(CC) -o tileedit -I../include -I$(QTDIR)/include -L$(QTDIR)/lib tileedit.cpp $(TEXT_IO) -lqt
++ $(CC) -o tileedit -I../include -I/usr/include/qt3 tileedit.cpp $(TEXT_IO) -lqt-mt
+ */
+
+
+diff -Nur old/nethack-3.4.3/win/X11/NetHack.ad nethack-3.4.3/win/X11/NetHack.ad
+--- old/nethack-3.4.3/win/X11/NetHack.ad 2014-01-11 15:21:06.106862231 -0500
++++ nethack-3.4.3/win/X11/NetHack.ad 2014-01-11 15:45:28.516909635 -0500
+@@ -3,13 +3,13 @@
+ ! The rip window applies if the GRAPHIC_TOMBSTONE option is turned on, and
+ ! requires a 12 pixel font for correct appearance.
+ !
+-NetHack*font: variable
++NetHack*font: fixed
+ NetHack*display_file*font: fixed
+ NetHack*tombstone*font: fixed
+ NetHack*text*rip*font: -*-times-medium-r-*-*-12-*-*-*-*-*-*-*
+ NetHack*menu*font: fixed
+ NetHack*text*font: fixed
+-NetHack*map*font: nh10
++NetHack*map*font: fixed
+
+ ! To use full-color tiles for the map, uncomment the tile file name.
+ ! If you use a 100dpi (or greater) monitor you may wish to double the
+@@ -19,8 +19,8 @@
+ ! the custom format - to enlarge an XPM file, use processing tools
+ ! such as XV or preferably PBMplus.
+ !
+-!NetHack.tile_file: x11tiles
+-!NetHack.double_tile_size: True
++NetHack.tile_file: x11tiles
++NetHack.double_tile_size: True
+ !
+ ! The annotation of pets.
+ !NetHack.pet_mark_bitmap: pet_mark.xbm