summarylogtreecommitdiffstats
path: root/no_static.patch
diff options
context:
space:
mode:
Diffstat (limited to 'no_static.patch')
-rw-r--r--no_static.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/no_static.patch b/no_static.patch
new file mode 100644
index 000000000000..ff69f91e8217
--- /dev/null
+++ b/no_static.patch
@@ -0,0 +1,50 @@
+commit 27dedfb68d079a8053f76d7eb83ed5fc7a810365
+Author: Anatol Pomozov <anatol.pomozov@gmail.com>
+Date: Sat Dec 9 10:32:22 2017 -0800
+
+ Remove static binary build
+
+ It fails to build at Arch as there is no static version of libcrypto
+
+ Change-Id: I36fd4917a834171a3c6cc37b85f6df212d9722aa
+
+diff --git a/Makefile b/Makefile
+index 013c6d8a..06d4d765 100644
+--- a/Makefile
++++ b/Makefile
+@@ -647,8 +647,6 @@ SIGNING_COMMON = scripts/image_signing/common_minimal.sh
+
+ # The unified firmware utility will eventually replace all the others
+ FUTIL_BIN = ${BUILD}/futility/futility
+-# But we still need both static (tiny) and dynamic (with openssl) versions.
+-FUTIL_STATIC_BIN = ${FUTIL_BIN}_s
+
+ # These are the executables that are now built in to futility. We'll create
+ # symlinks for these so the old names will still work.
+@@ -1125,12 +1123,7 @@ signing_install: ${SIGNING_SCRIPTS} ${SIGNING_SCRIPTS_DEV} ${SIGNING_COMMON}
+ # new Firmware Utility
+
+ .PHONY: futil
+-futil: ${FUTIL_STATIC_BIN} ${FUTIL_BIN}
+-
+-${FUTIL_STATIC_BIN}: LDLIBS += ${CRYPTO_STATIC_LIBS}
+-${FUTIL_STATIC_BIN}: ${FUTIL_STATIC_OBJS} ${UTILLIB}
+- @${PRINTF} " LD $(subst ${BUILD}/,,$@)\n"
+- ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} -static $^ ${LDLIBS}
++futil: ${FUTIL_BIN}
+
+ ${FUTIL_BIN}: LDLIBS += ${CRYPTO_LIBS} ${FWLIB20}
+ ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
+@@ -1138,10 +1131,10 @@ ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
+ ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} $^ ${LDLIBS}
+
+ .PHONY: futil_install
+-futil_install: ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
++futil_install: ${FUTIL_BIN}
+ @${PRINTF} " INSTALL futility\n"
+ ${Q}mkdir -p ${UB_DIR}
+- ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
++ ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN}
+ ${Q}for prog in ${FUTIL_SYMLINKS}; do \
+ ln -sf futility "${UB_DIR}/$$prog"; done
+