summarylogtreecommitdiffstats
path: root/no_static.patch
diff options
context:
space:
mode:
Diffstat (limited to 'no_static.patch')
-rw-r--r--no_static.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/no_static.patch b/no_static.patch
deleted file mode 100644
index 5bac160d1f68..000000000000
--- a/no_static.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 1f3e7f66..2103127f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -643,8 +643,6 @@ SIGNING_COMMON = scripts/image_signing/common_minimal.sh
-
- # The unified firmware utility will eventually replace all the others
- FUTIL_BIN = ${BUILD}/futility/futility
--# But we still need both static (tiny) and dynamic (with openssl) versions.
--FUTIL_STATIC_BIN = ${FUTIL_BIN}_s
-
- # These are the executables that are now built in to futility. We'll create
- # symlinks for these so the old names will still work.
-@@ -1112,12 +1110,7 @@ signing_install: ${SIGNING_SCRIPTS} ${SIGNING_SCRIPTS_DEV} ${SIGNING_COMMON}
- # new Firmware Utility
-
- .PHONY: futil
--futil: ${FUTIL_STATIC_BIN} ${FUTIL_BIN}
--
--${FUTIL_STATIC_BIN}: LDLIBS += ${CRYPTO_STATIC_LIBS} -lpthread
--${FUTIL_STATIC_BIN}: ${FUTIL_STATIC_OBJS} ${UTILLIB}
-- @${PRINTF} " LD $(subst ${BUILD}/,,$@)\n"
-- ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} -static $^ ${LDLIBS}
-+futil: ${FUTIL_BIN}
-
- ${FUTIL_BIN}: LDLIBS += ${CRYPTO_LIBS}
- ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
-@@ -1125,10 +1118,10 @@ ${FUTIL_BIN}: ${FUTIL_OBJS} ${UTILLIB} ${FWLIB20} ${UTILBDB}
- ${Q}${LD} -o $@ ${CFLAGS} ${LDFLAGS} $^ ${LDLIBS}
-
- .PHONY: futil_install
--futil_install: ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
-+futil_install: ${FUTIL_BIN}
- @${PRINTF} " INSTALL futility\n"
- ${Q}mkdir -p ${UB_DIR}
-- ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN} ${FUTIL_STATIC_BIN}
-+ ${Q}${INSTALL} -t ${UB_DIR} ${FUTIL_BIN}
- ${Q}for prog in ${FUTIL_SYMLINKS}; do \
- ln -sf futility "${UB_DIR}/$$prog"; done
-