summarylogtreecommitdiffstats
path: root/oci-cli.patch
diff options
context:
space:
mode:
Diffstat (limited to 'oci-cli.patch')
-rw-r--r--oci-cli.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/oci-cli.patch b/oci-cli.patch
deleted file mode 100644
index 4d74c1d88b46..000000000000
--- a/oci-cli.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -rupN oci-cli-2.24.2/setup.py oci-cli-2.24.2b/setup.py
---- oci-cli-2.24.2/setup.py 2021-04-27 19:55:25.000000000 -0400
-+++ oci-cli-2.24.2b/setup.py 2021-05-02 01:37:28.497145222 -0400
-@@ -30,24 +30,23 @@ with open_relative("README.rst") as f:
- readme = f.read()
-
- requires = [
-- 'oci==2.38.0',
-- 'arrow==0.17.0',
-+ 'oci',
-+ 'arrow',
- 'certifi',
-- 'click==6.7',
-- 'configparser==4.0.2',
-- 'cryptography==3.3.2',
-- 'jmespath==0.10.0',
-- 'python-dateutil>=2.5.3,<3.0.0',
-- 'pytz>=2016.10',
-- 'retrying==1.3.3',
-- 'six==1.14.0',
-- 'terminaltables==3.1.0',
-- 'pyOpenSSL==19.1.0',
-- 'PyYAML==5.3.1'
-+ 'click',
-+ 'cryptography',
-+ 'jmespath',
-+ 'python-dateutil',
-+ 'pytz',
-+ 'retrying',
-+ 'six',
-+ 'terminaltables',
-+ 'pyOpenSSL',
-+ 'PyYAML'
- ]
-
- extras = {
-- 'db': ['cx_Oracle==7.0']
-+ 'db': ['cx_Oracle']
- }
-
- fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.24.2/src/oci_cli/cli_root.py oci-cli-2.24.2b/src/oci_cli/cli_root.py
---- oci-cli-2.24.2/src/oci_cli/cli_root.py 2021-04-27 19:55:25.000000000 -0400
-+++ oci-cli-2.24.2b/src/oci_cli/cli_root.py 2021-05-02 01:59:25.633147095 -0400
-@@ -305,7 +305,7 @@ For information on configuration, see ht
- @click.option('--profile',
- default=Sentinel(DEFAULT_PROFILE), show_default=False,
- help='The profile in the config file to load. This profile will also be used to locate any default parameter values which have been specified in the OCI CLI-specific configuration file. [default: DEFAULT]')
--@click.option('--cli-rc-file', '--defaults-file',
-+@click.option('--cli-rc-file', '--defaults-file', 'defaults_file',
- default=cli_constants.CLI_RC_DEFAULT_LOCATION, show_default=True,
- is_eager=True, callback=eager_load_cli_rc_file,
- help='The path to the OCI CLI-specific configuration file, containing parameter default values and other configuration information such as command aliases and predefined queries. The --defaults-file option is deprecated and you should use the --cli-rc-file option instead.')