summarylogtreecommitdiffstats
path: root/opencl-autotools-Fix-linking-order-for-OpenCL-target.patch
diff options
context:
space:
mode:
Diffstat (limited to 'opencl-autotools-Fix-linking-order-for-OpenCL-target.patch')
-rw-r--r--opencl-autotools-Fix-linking-order-for-OpenCL-target.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/opencl-autotools-Fix-linking-order-for-OpenCL-target.patch b/opencl-autotools-Fix-linking-order-for-OpenCL-target.patch
new file mode 100644
index 000000000000..5ff91ff2578f
--- /dev/null
+++ b/opencl-autotools-Fix-linking-order-for-OpenCL-target.patch
@@ -0,0 +1,17 @@
+diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
+index de68a93ad5..f0e1de7797 100644
+--- a/src/gallium/targets/opencl/Makefile.am
++++ b/src/gallium/targets/opencl/Makefile.am
+@@ -23,11 +23,10 @@ lib@OPENCL_LIBNAME@_la_LIBADD = \
+ $(LIBELF_LIBS) \
+ $(DLOPEN_LIBS) \
+ -lclangCodeGen \
+- -lclangFrontendTool \
+ -lclangFrontend \
++ -lclangFrontendTool \
+ -lclangDriver \
+ -lclangSerialization \
+- -lclangCodeGen \
+ -lclangParse \
+ -lclangSema \
+ -lclangAnalysis \