summarylogtreecommitdiffstats
path: root/path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'path.patch')
-rw-r--r--path.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/path.patch b/path.patch
new file mode 100644
index 000000000000..4d9b679c6ab7
--- /dev/null
+++ b/path.patch
@@ -0,0 +1,60 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-02-02 12:46:46.432763024 +0100
++++ b/CMakeLists.txt 2016-02-02 12:51:42.589433577 +0100
+@@ -352,21 +352,21 @@
+
+ # Install the executable.
+ install(TARGETS ${PROJECT_NAME} DESTINATION bin/)
+-install(FILES res/DSLogic.fw DESTINATION bin/res/)
+-install(FILES res/DSLogic33.bin DESTINATION bin/res/)
+-install(FILES res/DSLogic50.bin DESTINATION bin/res/)
+-install(FILES res/DSLogicPro.fw DESTINATION bin/res/)
+-install(FILES res/DSLogicPro.bin DESTINATION bin/res/)
+-install(FILES res/DSCope.fw DESTINATION bin/res/)
+-install(FILES res/DSCope.bin DESTINATION bin/res/)
+-install(FILES res/DSLogic0.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic0.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic1.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic1.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic2.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic2.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSCope1.dsc DESTINATION bin/res/)
+-install(FILES res/DSCope1.def.dsc DESTINATION bin/res/)
++install(FILES res/DSLogic.fw DESTINATION share/dsview/)
++install(FILES res/DSLogic33.bin DESTINATION share/dsview/)
++install(FILES res/DSLogic50.bin DESTINATION share/dsview/)
++install(FILES res/DSLogicPro.fw DESTINATION share/dsview/)
++install(FILES res/DSLogicPro.bin DESTINATION share/dsview/)
++install(FILES res/DSCope.fw DESTINATION share/dsview/)
++install(FILES res/DSCope.bin DESTINATION share/dsview/)
++install(FILES res/DSLogic0.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic0.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic1.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic1.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic2.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic2.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSCope1.dsc DESTINATION share/dsview/)
++install(FILES res/DSCope1.def.dsc DESTINATION share/dsview/)
+
+ #===============================================================================
+ #= Packaging (handled by CPack)
+diff -Naur a/pv/devicemanager.cpp b/pv/devicemanager.cpp
+--- a/pv/devicemanager.cpp 2016-02-02 12:46:46.439429691 +0100
++++ b/pv/devicemanager.cpp 2016-02-02 12:53:09.256101381 +0100
+@@ -103,12 +103,16 @@
+
+ // Check If DSL hardware driver
+ if (strncmp(driver->name, "virtual", 7)) {
++ /*
+ QDir dir(QCoreApplication::applicationDirPath());
+ if (!dir.cd("res"))
+ return driver_devices;
+ QString str = dir.absolutePath() + "/";
+ QString str_utf8 = QString::fromLocal8Bit(str.toLocal8Bit());
+ strcpy(config_path, str_utf8.toUtf8().data());
++ */
++ // dirty
++ strcpy(config_path, "/usr/share/dsview/");
+ }
+
+ // Do the scan