summarylogtreecommitdiffstats
path: root/pid-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'pid-path.patch')
-rw-r--r--pid-path.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/pid-path.patch b/pid-path.patch
new file mode 100644
index 000000000000..09194a128b0e
--- /dev/null
+++ b/pid-path.patch
@@ -0,0 +1,24 @@
+--- Makefile.am 2012-07-17 08:53:51.000000000 +0200
++++ Makefile.am 2012-11-20 21:56:11.000000000 +0100
+@@ -29,8 +29,8 @@
+ $(INSTALL) -d $(DESTDIR)$(localstatedir)/opendnssec/signconf
+ $(INSTALL) -d $(DESTDIR)$(localstatedir)/opendnssec/unsigned
+ $(INSTALL) -d $(DESTDIR)$(localstatedir)/opendnssec/signed
+- $(INSTALL) -d $(DESTDIR)$(localstatedir)/run
+- $(INSTALL) -d $(DESTDIR)$(localstatedir)/run/opendnssec
++ $(INSTALL) -d $(DESTDIR)/run
++ $(INSTALL) -d $(DESTDIR)/run/opendnssec
+
+ docs:
+ (cd libhsm; $(MAKE) doxygen)
+--- m4/opendnssec_common.m4 2012-11-01 11:56:59.000000000 +0100
++++ m4/opendnssec_common.m4 2012-11-20 21:52:56.000000000 +0100
+@@ -17,7 +17,7 @@
+ OPENDNSSEC_DATA_DIR=$full_datadir/opendnssec
+ OPENDNSSEC_SYSCONF_DIR=$full_sysconfdir/opendnssec
+ OPENDNSSEC_LOCALSTATE_DIR="$full_localstatedir/opendnssec"
+-OPENDNSSEC_PID_DIR="$full_localstatedir/run/opendnssec"
++OPENDNSSEC_PID_DIR="/run/opendnssec"
+
+ AC_SUBST([OPENDNSSEC_BIN_DIR])
+ AC_SUBST([OPENDNSSEC_SBIN_DIR])