summarylogtreecommitdiffstats
path: root/pkg_upgrader.sh
diff options
context:
space:
mode:
Diffstat (limited to 'pkg_upgrader.sh')
-rwxr-xr-xpkg_upgrader.sh1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkg_upgrader.sh b/pkg_upgrader.sh
index bc89733ebb33..157c9dbec5dc 100755
--- a/pkg_upgrader.sh
+++ b/pkg_upgrader.sh
@@ -7,6 +7,7 @@
#
# DON'T FORGET TO REPLACE `yay` to your favorite AUR helper
# #########################################################
+cd $(dirname "$0")
RELEASE_TIMESTAMP=$(curl -sL https://download-installer.cdn.mozilla.net/pub/firefox/nightly/latest-mozilla-central-l10n/ | grep -A2 "firefox-$(cat PKGBUILD | grep -oP "^_version=\K(.*)" | awk '{print $1}').ru.linux-$(uname -m).tar.bz2\"" | tail -n1 | cut -f2 -d'>' | cut -f1 -d'<' | date +"%s" -f -)
LOCAL_TIMESTAMP=$(cat ~/.firefox-nightly-ru.release.timestamp || echo 0)