summarylogtreecommitdiffstats
path: root/plugin_path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'plugin_path.patch')
-rw-r--r--plugin_path.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/plugin_path.patch b/plugin_path.patch
new file mode 100644
index 000000000000..295858dbdc2f
--- /dev/null
+++ b/plugin_path.patch
@@ -0,0 +1,12 @@
+diff -ruN 1/src/CMakeLists.txt 2/src/CMakeLists.txt
+--- 1/src/CMakeLists.txt 2016-09-28 23:02:41.000000000 +0200
++++ 2/src/CMakeLists.txt 2016-10-07 00:34:34.000000000 +0200
+@@ -45,7 +45,7 @@
+ set(GIT_BRANCH "Unknown")
+ endif()
+ add_definitions(-DGIT_BRANCH=${GIT_BRANCH})
+-add_definitions(-DDEFAULT_PLUGIN_PATH=${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/edb)
++add_definitions(-DDEFAULT_PLUGIN_PATH=${DEFAULT_PLUGIN_PATH})
+
+ include_directories(
+ "capstone-edb"