summarylogtreecommitdiffstats
path: root/proton-sanitize_makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'proton-sanitize_makefile.patch')
-rw-r--r--proton-sanitize_makefile.patch33
1 files changed, 32 insertions, 1 deletions
diff --git a/proton-sanitize_makefile.patch b/proton-sanitize_makefile.patch
index 144291d96a29..d1b154cf7ab5 100644
--- a/proton-sanitize_makefile.patch
+++ b/proton-sanitize_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile.in b/Makefile.in
-index 6cfb8c3..fd90f1e 100644
+index 6cfb8c3..454da82 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -115,6 +115,37 @@ index 6cfb8c3..fd90f1e 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
+@@ -1080,14 +1102,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+ mkdir -p $(FONTS_OBJ)/source-han
+ # Do not immediately create the target file, so that make is interrupted
+ # it will restart again
+- afdko makeotfexe -f $($(notdir $@)_CIDFONT) -omitMacNames -ff $($(notdir $@)_FEATURES) \
++ makeotfexe -f $($(notdir $@)_CIDFONT) -omitMacNames -ff $($(notdir $@)_FEATURES) \
+ -lic ADOBE -mf $($(notdir $@)_MENUNAMEDB) -r -nS -cs 25 -ch $($(notdir $@)_UNISOURCE) \
+ -ci $($(notdir $@)_SEQUENCES) -o $@.tmp
+- afdko tx -cff +S -no_futile $($(notdir $@)_CIDFONT) $@.cff
++ tx -cff +S -no_futile $($(notdir $@)_CIDFONT) $@.cff
+ # sftnedit uses a hardcoded temporary file in the local directory, so we have
+ # to run it in a dedicated temporary directory to prevent concurrent instances
+ # to step onto each other's feet
+- (TEMP_DIR=`mktemp -d` && cd $$TEMP_DIR && afdko sfntedit -a CFF=$(abspath $($(notdir $@)).cff) $(abspath $@.tmp) && rm -fr $$TEMP_DIR)
++ (TEMP_DIR=`mktemp -d` && cd $$TEMP_DIR && sfntedit -a CFF=$(abspath $($(notdir $@)).cff) $(abspath $@.tmp) && rm -fr $$TEMP_DIR)
+ mv $@.tmp $@
+
+ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1097,10 +1119,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+ ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
+
+ $(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
+- afdko otf2otc -o $@ $^
++ otf2otc -o $@ $^
+
+ $(msgothic.ttc): $(msgothic.ttf) $(mspgothic.ttf) $(msuigothic.ttf)
+- afdko otf2otc -o $@ $^
++ otf2otc -o $@ $^
+
+ $(micross.ttf): $(noto_sans.ttf) $(noto_sans_arabic.ttf) $(noto_sans_armenian.ttf) $(noto_sans_bengali.ttf) $(noto_sans_coptic.ttf) \
+ $(noto_sans_georgian.ttf) $(noto_sans_gujarati.ttf) $(noto_sans_hebrew.ttf) $(noto_sans_khmer.ttf) $(noto_sans_tamil.ttf) \
diff --git a/configure.sh b/configure.sh
index 337781e..0ceabc5 100755
--- a/configure.sh