summarylogtreecommitdiffstats
path: root/publish.sh
diff options
context:
space:
mode:
Diffstat (limited to 'publish.sh')
-rw-r--r--publish.sh23
1 files changed, 23 insertions, 0 deletions
diff --git a/publish.sh b/publish.sh
new file mode 100644
index 000000000000..87fbf23943b2
--- /dev/null
+++ b/publish.sh
@@ -0,0 +1,23 @@
+#!/usr/bin/env bash
+
+scripts=(sc tc j)
+widths=(compressed condensed extended normal wide)
+
+git commit --allow-empty "update package"
+for script in "${scripts[@]}"
+do
+ for width in "${widths[@]}"
+ do
+ pkgname="glow-sans-${script}-${width}"
+ echo "updating $pkgname"
+ sed -i -e "s/PH_SCRIPT/${script}/g" PKGBUILD
+ sed -i -e "s/PH_WIDTH/${width}/g" PKGBUILD
+ updpkgsums
+ makepkg --printsrcinfo > .SRCINFO
+ git add .
+ git commit -m "updates $pkgname"
+ git remote set-url aur "ssh://aur@aur.archlinux.org/$pkgname"
+ git push aur master
+ git reset --hard HEAD~1
+ done
+done