summarylogtreecommitdiffstats
path: root/purge-ext.patch
diff options
context:
space:
mode:
Diffstat (limited to 'purge-ext.patch')
-rw-r--r--purge-ext.patch13
1 files changed, 6 insertions, 7 deletions
diff --git a/purge-ext.patch b/purge-ext.patch
index 504e3c30ff6c..fd0c1fc8f74c 100644
--- a/purge-ext.patch
+++ b/purge-ext.patch
@@ -15,7 +15,7 @@ Last-Update: 2013-09-28
cd odpdom && $(MAKE) libODP.a
cd src && $(MAKE)
p4vasp_config:
-@@ -143,7 +143,7 @@
+@@ -144,7 +144,7 @@
cd ext && sh clean.sh
clean: clean_p4vasp clean_odpdom
@@ -26,13 +26,12 @@ Last-Update: 2013-09-28
mkdir -p $(SITE_PACKAGES)/p4vasp
--- src/Configuration.mk
+++ src/Configuration.mk
-@@ -1,5 +1,5 @@
+@@ -1,6 +1,6 @@
-LIBS= -L../odpdom -lODP `python2 fltk-config.py --use-gl --ldstaticflags` -lpthread
--CFLAGS= -g -O0 -fpic -Wall $(FLAGS) `python2 fltk-config.py --cxxflags` -I$(PYINCLUDE) \
+LIBS= -L../odpdom -lODP $(shell fltk-config --use-gl --ldflags) -lGLU -lGL -lm -lpthread
-+CFLAGS= -g -O0 -fpic -Wall $(FLAGS) $(shell fltk-config --cxxflags) -I$(PYINCLUDE) \
+ CFLAGS?= -g -Wall
+-CFLAGS+= -fpic $(FLAGS) `python2 fltk-config.py --cxxflags` -I$(PYINCLUDE) \
++CFLAGS+= -fpic $(FLAGS) $(shell fltk-config --cxxflags) -I$(PYINCLUDE) \
-Iinclude -I../odpdom/include
PYINCLUDE=`python2 -c "import sys;import os.path;print os.path.join(sys.prefix,\"include\",\"python\"+sys.version[:3])"`
--LDFLAGS= -shared -L.
-\ No newline at end of file
-+LDFLAGS= -shared -L.
+ LDFLAGS+= -shared -L.