summarylogtreecommitdiffstats
path: root/python-lib-dir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'python-lib-dir.patch')
-rw-r--r--python-lib-dir.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/python-lib-dir.patch b/python-lib-dir.patch
new file mode 100644
index 000000000000..bafa83ef6261
--- /dev/null
+++ b/python-lib-dir.patch
@@ -0,0 +1,24 @@
+diff -Naur a/daemon/Makefile.am b/daemon/Makefile.am
+--- a/daemon/Makefile.am 2019-10-12 17:26:38.000000000 -0400
++++ b/daemon/Makefile.am 2019-11-13 14:56:10.154495566 -0500
+@@ -14,7 +14,7 @@
+ DOCS = doc
+ endif
+
+-PYTHONLIBDIR=$(subst site-packages,dist-packages,$(pythondir))
++PYTHONLIBDIR=$(pythondir)
+
+ SUBDIRS = proto $(DOCS)
+
+diff -Naur a/ns3/Makefile.am b/ns3/Makefile.am
+--- a/ns3/Makefile.am 2019-10-12 17:26:38.000000000 -0400
++++ b/ns3/Makefile.am 2019-11-13 14:56:18.600662969 -0500
+@@ -9,7 +9,7 @@
+
+ if WANT_PYTHON
+
+-PYTHONLIBDIR=$(subst site-packages,dist-packages,$(pythondir))
++PYTHONLIBDIR=$(pythondir)
+
+ SETUPPY = setup.py
+ SETUPPYFLAGS = -v