summarylogtreecommitdiffstats
path: root/python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'python.patch')
-rw-r--r--python.patch77
1 files changed, 0 insertions, 77 deletions
diff --git a/python.patch b/python.patch
deleted file mode 100644
index 205a2d12ee35..000000000000
--- a/python.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a4a073f2e..4025bc894 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -28,6 +28,10 @@ MESSAGE(STATUS "CMake version " ${CMAKE_VERSION} " detected")
- cmake_minimum_required(VERSION 3.5.1)
- cmake_policy(VERSION 3.0)
-
-+if(POLICY CMP0072)
-+ cmake_policy(SET CMP0072 OLD)
-+endif()
-+
- # Remove the following when the version check is at least 2.8.4
- SET(CMAKE_LEGACY_CYGWIN_WIN32 0)
-
-diff --git a/samples/luxcoreconsole/CMakeLists.txt b/samples/luxcoreconsole/CMakeLists.txt
-index dc3f5d8cf..a8b429814 100644
---- a/samples/luxcoreconsole/CMakeLists.txt
-+++ b/samples/luxcoreconsole/CMakeLists.txt
-@@ -28,4 +28,4 @@ set(LUXCORECONSOLE_SRCS
-
- add_executable(luxcoreconsole ${LUXCORECONSOLE_SRCS})
-
--TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-\ No newline at end of file
-+TARGET_LINK_LIBRARIES(luxcoreconsole ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
-diff --git a/samples/luxcoredemo/CMakeLists.txt b/samples/luxcoredemo/CMakeLists.txt
-index c140dc23b..c8cba9880 100644
---- a/samples/luxcoredemo/CMakeLists.txt
-+++ b/samples/luxcoredemo/CMakeLists.txt
-@@ -29,4 +29,4 @@ set(LUXCORELIBDEMO_SRCS
- add_executable(luxcoredemo ${LUXCORELIBDEMO_SRCS})
- add_definitions(${VISIBILITY_FLAGS})
-
--TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcoredemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
-diff --git a/samples/luxcorescenedemo/CMakeLists.txt b/samples/luxcorescenedemo/CMakeLists.txt
-index 90c1967cd..aa024f650 100644
---- a/samples/luxcorescenedemo/CMakeLists.txt
-+++ b/samples/luxcorescenedemo/CMakeLists.txt
-@@ -29,4 +29,4 @@ set(LUXCORESCENEDEMO_SRCS
- add_executable(luxcorescenedemo ${LUXCORESCENEDEMO_SRCS})
- add_definitions(${VISIBILITY_FLAGS})
-
--TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${OPENCL_LIBRARIES})
-+TARGET_LINK_LIBRARIES(luxcorescenedemo ${LUXCORE_LIBRARY} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${OPENCL_LIBRARIES})
-diff --git a/samples/luxcoreui/CMakeLists.txt b/samples/luxcoreui/CMakeLists.txt
-index 33b50b3d0..ba1982a42 100644
---- a/samples/luxcoreui/CMakeLists.txt
-+++ b/samples/luxcoreui/CMakeLists.txt
-@@ -88,4 +91,5 @@ TARGET_LINK_LIBRARIES(luxcoreui
- ${OPENGL_LIBRARIES}
- ${GTK3_LIBRARIES}
- ${Boost_LIBRARIES}
-+ ${PYTHON_LIBRARIES}
- ${OPENCL_LIBRARIES})
-diff --git a/tests/benchsimple/CMakeLists.txt b/tests/benchsimple/CMakeLists.txt
-index 3ac004b2b..b2abe340c 100644
---- a/tests/benchsimple/CMakeLists.txt
-+++ b/tests/benchsimple/CMakeLists.txt
-@@ -22,4 +22,4 @@ link_directories (${LuxRays_LIB_DIR})
- add_executable(benchsimple benchsimple.cpp)
- add_definitions(${VISIBILITY_FLAGS})
- remove_definitions("-DLUXCORE_DLL")
--target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${TBB_LIBRARY} )
-+target_link_libraries(benchsimple luxrays ${EMBREE_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} )
-diff --git a/tests/luxcoreimplserializationdemo/CMakeLists.txt b/tests/luxcoreimplserializationdemo/CMakeLists.txt
-index c8d9c4aa9..1dc6b7c63 100644
---- a/tests/luxcoreimplserializationdemo/CMakeLists.txt
-+++ b/tests/luxcoreimplserializationdemo/CMakeLists.txt
-@@ -30,4 +30,4 @@ include_directories(${LuxRays_SOURCE_DIR}/deps/bcd-1.1/include)
-
- add_executable(luxcoreimplserializationdemo ${LUXCOREIMPL_SERIALIZATIONDEMO_SRCS})
-
--TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})
-\ Brak znaku nowej linii na końcu pliku
-+TARGET_LINK_LIBRARIES(luxcoreimplserializationdemo luxcore slg-core slg-film slg-kernels luxrays bcd opensubdiv openvdb ${BLOSC_LIBRARY} ${EMBREE_LIBRARY} ${OIDN_LIBRARY} ${PYTHON_LIBRARIES} ${TBB_LIBRARY} ${TIFF_LIBRARIES} ${TIFF_LIBRARIES} ${OPENEXR_LIBRARIES} ${PNG_LIBRARIES} ${JPEG_LIBRARIES})