summarylogtreecommitdiffstats
path: root/relro.patch
diff options
context:
space:
mode:
Diffstat (limited to 'relro.patch')
-rw-r--r--relro.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/relro.patch b/relro.patch
new file mode 100644
index 000000000000..d63d0887b9fb
--- /dev/null
+++ b/relro.patch
@@ -0,0 +1,11 @@
+diff --git a/library/Makefile b/library/Makefile
+index 9b4e856..8a13662 100644
+--- a/library/Makefile
++++ b/library/Makefile
+@@ -14,5 +14,5 @@ clean:
+ $(CC) -c -o $@ $< $(CFLAGS)
+
+ libevdi.so: evdi_lib.o
+- $(CC) $^ -o $@ -lc -lgcc -shared -Wl,-soname,libevdi.so.0
++ $(CC) $^ -o $@ -lc -lgcc -shared -Wl,-soname,libevdi.so.0 $(LDFLAGS)
+