summarylogtreecommitdiffstats
path: root/remove-defunct.patch
diff options
context:
space:
mode:
Diffstat (limited to 'remove-defunct.patch')
-rw-r--r--remove-defunct.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/remove-defunct.patch b/remove-defunct.patch
new file mode 100644
index 000000000000..3a8e3151e10d
--- /dev/null
+++ b/remove-defunct.patch
@@ -0,0 +1,63 @@
+--- a/finalchanctl
++++ /dev/null
+@@ -1,23 +0,0 @@
+-#!/usr/bin/env python3
+-# Copyright 2016 ring <ring@8chan.co>
+-# Copying and distribution of this file, with or without modification,
+-# are permitted in any medium without royalty provided the copyright
+-# notice and this notice are preserved. This file is offered as-is,
+-# without any warranty.
+-
+-"""infinityctl variant for finalchan.net"""
+-
+-import os
+-
+-import infinitychan
+-import infinityctl
+-
+-infinitychan.dom = "https://finalchan.net"
+-infinitychan.mod = "https://finalchan.net/mod.php?"
+-infinitychan.sys = "https://finalchan.net"
+-infinitychan.media_base = "https://finalchan.net"
+-infinitychan.media = "https://finalchan.net/{board}/src/{tim}{ext}"
+-infinitychan.media_dedup = infinitychan.media
+-infinitychan.config = os.path.join(os.path.expanduser("~"), ".finalchanctl")
+-
+-infinityctl.main()
+--- a/setup.py
++++ b/setup.py
+@@ -18,7 +18,7 @@
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
+ 'Intended Audience :: End Users/Desktop'],
+ py_modules=['infinitychan', 'infinityctl', 'botmod', 'threadviewer', 'urls'],
+- scripts=['infinityctl', 'onionctl', 'finalchanctl', 'vichanctl'],
++ scripts=['infinityctl', 'onionctl'],
+ install_requires=['urllib3'],
+ python_requires='>=3.0'
+ )
+--- a/vichanctl
++++ /dev/null
+@@ -1,23 +0,0 @@
+-#!/usr/bin/env python3
+-# Copyright 2016 ring <ring@8chan.co>
+-# Copying and distribution of this file, with or without modification,
+-# are permitted in any medium without royalty provided the copyright
+-# notice and this notice are preserved. This file is offered as-is,
+-# without any warranty.
+-
+-"""infinityctl variant for 8ch.pl (soon to become vichan.net)"""
+-
+-import os
+-
+-import infinitychan
+-import infinityctl
+-
+-infinitychan.dom = "https://8ch.pl"
+-infinitychan.mod = "https://8ch.pl/mod.php?"
+-infinitychan.sys = "https://8ch.pl"
+-infinitychan.media_base = "https://8ch.pl"
+-infinitychan.media = "https://8ch.pl/{board}/src/{tim}{ext}"
+-infinitychan.media_dedup = infinitychan.media
+-infinitychan.config = os.path.join(os.path.expanduser("~"), ".vichanctl")
+-
+-infinityctl.main()