summarylogtreecommitdiffstats
path: root/remove_hcc_path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'remove_hcc_path.patch')
-rw-r--r--remove_hcc_path.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/remove_hcc_path.patch b/remove_hcc_path.patch
new file mode 100644
index 000000000000..f3d21a74e5b2
--- /dev/null
+++ b/remove_hcc_path.patch
@@ -0,0 +1,19 @@
+*** clang-ocl-rocm-3.5.0/CMakeLists.txt.bak 2020-06-20 18:53:09.243264978 +0200
+--- clang-ocl-rocm-3.5.0/CMakeLists.txt 2020-06-20 18:54:01.412910087 +0200
+***************
+*** 15,21 ****
+ if(CMAKE_CXX_COMPILER MATCHES ".*hcc")
+ set(HCC_EXE ${CMAKE_CXX_COMPILER})
+ else()
+! find_program(HCC_EXE NAMES hcc clang PATHS /opt/rocm/hcc/bin)
+ endif()
+
+ get_filename_component(HCC_BIN ${HCC_EXE} DIRECTORY)
+--- 15,21 ----
+ if(CMAKE_CXX_COMPILER MATCHES ".*hcc")
+ set(HCC_EXE ${CMAKE_CXX_COMPILER})
+ else()
+! find_program(HCC_EXE NAMES hcc clang PATHS /opt/rocm/llvm/bin)
+ endif()
+
+ get_filename_component(HCC_BIN ${HCC_EXE} DIRECTORY)