summarylogtreecommitdiffstats
path: root/renovate.json
diff options
context:
space:
mode:
Diffstat (limited to 'renovate.json')
-rw-r--r--renovate.json25
1 files changed, 25 insertions, 0 deletions
diff --git a/renovate.json b/renovate.json
new file mode 100644
index 000000000000..630d4773eb8c
--- /dev/null
+++ b/renovate.json
@@ -0,0 +1,25 @@
+{
+ "$schema": "https://docs.renovatebot.com/renovate-schema.json",
+
+ "extends": ["config:base"],
+
+ "assignees": ["languitar"],
+ "reviewers": ["languitar"],
+
+ "postUpgradeTasks": {
+ "commands": ["./post-update.sh"],
+ "fileFilters": ["PKGBUILD", ".SRCINFO"],
+ "executionMode": "branch"
+ },
+
+ "regexManagers": [
+ {
+ "fileMatch": ["^PKGBUILD$"],
+ "matchStrings": [
+ "pkgver=(?<currentValue>.*?)\n"
+ ],
+ "depNameTemplate": "yaml-language-server",
+ "datasourceTemplate": "npm"
+ }
+ ]
+}