summarylogtreecommitdiffstats
path: root/repo_upgrader.sh
diff options
context:
space:
mode:
Diffstat (limited to 'repo_upgrader.sh')
-rwxr-xr-xrepo_upgrader.sh10
1 files changed, 10 insertions, 0 deletions
diff --git a/repo_upgrader.sh b/repo_upgrader.sh
new file mode 100755
index 000000000000..0a315ae8fb2c
--- /dev/null
+++ b/repo_upgrader.sh
@@ -0,0 +1,10 @@
+#!/bin/bash
+# ###################################################
+# You can use this script as
+# cronjob (or something lika that)
+# to automatically update package repository
+#
+# This script can be useful ONLY for repo contributors
+# ####################################################
+cd $(dirname "$0")
+./update.sh && git pull && makepkg --printsrcinfo > .SRCINFO && git add PKGBUILD .SRCINFO && ./update.sh | grep -oP "^\w+: [0-9a-z.]+, \w+: \K([0-9a-z.]+)$" | awk '{print "Update to " $1}' | git commit -F - && git push