summarylogtreecommitdiffstats
path: root/reproducible-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'reproducible-build.patch')
-rw-r--r--reproducible-build.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/reproducible-build.patch b/reproducible-build.patch
new file mode 100644
index 000000000000..1ec6caeec3ea
--- /dev/null
+++ b/reproducible-build.patch
@@ -0,0 +1,20 @@
+diff --git a/Makefile b/Makefile
+index 475c85b..2800d44 100644
+--- a/Makefile
++++ b/Makefile
+@@ -37,13 +37,13 @@ build:
+ cargo build
+
+ release:
+- cargo build --release
++ cargo build --release --locked
+
+ lint:
+ cargo clippy -- -D warnings
+
+ test:
+- cargo test
++ cargo test --release --locked
+
+ clean:
+ cargo clean