summarylogtreecommitdiffstats
path: root/rust_1.50.patch
diff options
context:
space:
mode:
Diffstat (limited to 'rust_1.50.patch')
-rw-r--r--rust_1.50.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/rust_1.50.patch b/rust_1.50.patch
new file mode 100644
index 000000000000..e7edd7b6cf83
--- /dev/null
+++ b/rust_1.50.patch
@@ -0,0 +1,74 @@
+
+# HG changeset patch
+# User Emilio Cobos Álvarez <emilio@crisal.io>
+# Date 1609006565 0
+# Node ID 0e8f444683cb9c4079d3b2250f32f986043ea582
+# Parent 55097a5cf353f1b2a2228820bdf26bb69a1372a0
+Bug 1684261 - Fix build with rust nightly. r=jrmuizel, a=RyanVM
+
+Fixes errors like:
+
+ dependency (nix) specification is ambiguous. Only one of `branch`, `tag` or `rev` is allowed.
+
+I've left the most specific dependency, but for wgpu the rev is not
+right, so I've kept the branch which effectively preserves behavior.
+
+Differential Revision: https://phabricator.services.mozilla.com/D100485
+
+diff --git a/.cargo/config.in b/.cargo/config.in
+--- a/.cargo/config.in
++++ b/.cargo/config.in
+@@ -1,16 +1,16 @@
+ # This file contains vendoring instructions for cargo.
+ # It was generated by `mach vendor rust`.
+ # Please do not edit.
+
+ [source."https://github.com/shravanrn/nix/"]
+-branch = "r0.13.1"
+ git = "https://github.com/shravanrn/nix/"
+ replace-with = "vendored-sources"
++rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+
+ [source."https://github.com/mozilla/rkv"]
+ git = "https://github.com/mozilla/rkv"
+ replace-with = "vendored-sources"
+ rev = "e3c3388e6632cf55e08d773b32e58b1cab9b2731"
+
+ [source."https://github.com/mozilla/neqo"]
+ git = "https://github.com/mozilla/neqo"
+diff --git a/Cargo.lock b/Cargo.lock
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -3195,17 +3195,17 @@ source = "registry+https://github.com/ru
+ checksum = "0cdc457076c78ab54d5e0d6fa7c47981757f1e34dc39ff92787f217dede586c4"
+ dependencies = [
+ "unreachable",
+ ]
+
+ [[package]]
+ name = "nix"
+ version = "0.13.1"
+-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
++source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+ dependencies = [
+ "bitflags",
+ "cc",
+ "cfg-if",
+ "libc",
+ "void",
+ ]
+
+diff --git a/Cargo.toml b/Cargo.toml
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -68,8 +68,8 @@
+ libudev-sys = { path = "dom/webauthn/libudev-sys" }
+ packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
+ rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="d510da5999a744c563b0acd18056069d1698273f" }
+-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3", rev = "20191ad2f370afd6d247edcb9ff9da32d3bedb9c" }
++nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
++spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3" }
+ # failure's backtrace feature might break our builds, see bug 1608157.
+ failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
+ failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }