summarylogtreecommitdiffstats
path: root/sdl_sound-pkgconfig.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sdl_sound-pkgconfig.patch')
-rw-r--r--sdl_sound-pkgconfig.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/sdl_sound-pkgconfig.patch b/sdl_sound-pkgconfig.patch
new file mode 100644
index 000000000000..a7b48395ed1f
--- /dev/null
+++ b/sdl_sound-pkgconfig.patch
@@ -0,0 +1,53 @@
+diff -r 719dade41745 Makefile.am
+--- a/Makefile.am Wed Aug 15 23:52:18 2012 -0400
++++ b/Makefile.am Thu Nov 28 18:42:40 2013 +0100
+@@ -1,8 +1,8 @@
+ lib_LTLIBRARIES = libSDL_sound.la
+
+ SUBDIRS = decoders . playsound
+
+-libSDL_soundincludedir = $(includedir)/SDL
++libSDL_soundincludedir = $(includedir)/SDL2
+ libSDL_soundinclude_HEADERS = \
+ SDL_sound.h
+
+@@ -49,3 +49,5 @@
+ echo >> $(distdir)/docs/README
+ rm -rf `find $(distdir) -type d -name ".svn"`
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = SDL_sound.pc
+diff -r 719dade41745 SDL_sound.pc.in
+--- /dev/null Thu Jan 01 00:00:00 1970 +0000
++++ b/SDL_sound.pc.in Thu Nov 28 18:42:40 2013 +0100
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: SDL_sound
++Description: audio decoding library for Simple DirectMedia Layer
++Version: @VERSION@
++Requires: sdl2 >= @SDL_VERSION@
++Libs: -L${libdir} -lSDL_sound
++Cflags: -I${includedir}/SDL2
+diff -r 719dade41745 configure.in
+--- a/configure.in Wed Aug 15 23:52:18 2012 -0400
++++ b/configure.in Thu Nov 28 18:42:40 2013 +0100
+@@ -107,7 +107,8 @@
+ dnl ---------------------------------------------------------------------
+
+ dnl Check for SDL
+-SDL_VERSION=1.2.0
++SDL_VERSION=2.0.0
++AC_SUBST(SDL_VERSION)
+ AM_PATH_SDL($SDL_VERSION,
+ :,
+ AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
+@@ -339,4 +340,5 @@
+ decoders/timidity/Makefile
+ decoders/libmpg123/Makefile
+ playsound/Makefile
++SDL_sound.pc
+ ])