summarylogtreecommitdiffstats
path: root/setup.py.patch
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py.patch')
-rw-r--r--setup.py.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/setup.py.patch b/setup.py.patch
new file mode 100644
index 000000000000..89580b7e60b4
--- /dev/null
+++ b/setup.py.patch
@@ -0,0 +1,19 @@
+--- setup.py 2019-08-11 16:34:25.584021489 -0400
++++ setup.py 2019-08-11 16:34:54.790714182 -0400
+@@ -117,7 +117,6 @@
+ 'meta', # for livecode.py plugin, which is enabled by default
+ 'nbformat', # for Jupyter notebook integration
+ 'pylint','pyflakes', # coding syntax standards
+- 'setupext-janitor >= 1.1', # extend `setup.py clean` #1055,#1255
+ 'shortcutter', # desktop integration (#1243)
+ 'sphinx', # rST plugin
+ 'future', # python 2/3 compatibility layer, same with 'six'
+@@ -169,7 +168,7 @@
+ setup_requires=setup_requires,
+ install_requires=user_requires,
+ entry_points=define_entry_points(),
+- cmdclass={'clean': janitor.CleanCommand} # clean more than setuptools, #1055
++ cmdclass=cmd_classes, # clean more than setuptools, #1055
+ )
+
+ #@@language python