summarylogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..f8e2b7c06034
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+setup(
+ name='ogr2osm',
+ version='0.1',
+ author='pnorman',
+ author_email='penorman@mac.com',
+ description="pnorman's version of UVM's Rewrite of ogr2osm",
+ license='MIT',
+ url='https://github.com/pnorman/ogr2osm/',
+ install_requires=[
+ 'GDAL'
+ ],
+ py_modules=[
+ 'ogr2osm',
+ 'geom',
+ ],
+ entry_points={
+ 'console_scripts': [
+ 'ogr2osm=ogr2osm:main',
+ ]
+ }
+)