summarylogtreecommitdiffstats
path: root/slashem-0.0.7E7F3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'slashem-0.0.7E7F3.patch')
-rw-r--r--slashem-0.0.7E7F3.patch149
1 files changed, 73 insertions, 76 deletions
diff --git a/slashem-0.0.7E7F3.patch b/slashem-0.0.7E7F3.patch
index 25c0a98bc46e..5e07e8feac16 100644
--- a/slashem-0.0.7E7F3.patch
+++ b/slashem-0.0.7E7F3.patch
@@ -1,75 +1,5 @@
---- Makefile.bak 2015-07-14 12:30:58.723692095 -0800
-+++ Makefile 2015-07-14 13:03:55.940290421 -0800
-@@ -17,15 +17,15 @@
- PREFIX = /usr
- GAME = slashem
- # GAME = slashem.prg
--GAMEUID = games
--GAMEGRP = bin
-+GAMEUID = root
-+GAMEGRP = games
-
- # Permissions - some places use setgid instead of setuid, for instance
- # See also the option "SECURE" in include/config.h
--GAMEPERM = 04755
--FILEPERM = 0644
-+GAMEPERM = 02755
-+FILEPERM = 0664
- EXEPERM = 0755
--DIRPERM = 0755
-+DIRPERM = 0775
- VARFILEPERM = 0644
- VARDIRPERM = 0755
-
-@@ -40,7 +40,7 @@
- # These must agree with the definitions in unixconf.h
-
- # Defs. for non file areas support.
--GAMEDIR = $(PREFIX)/local/slashemdir
-+GAMEDIR = $(PREFIX)/var/games/$(GAME)
- VARDIR = $(GAMEDIR)
- FILE_AREA_VAR = $(VARDIR)
- FILE_AREA_SAVE = $(VARDIR)/save
-@@ -49,7 +49,7 @@
- FILE_AREA_DOC = $(GAMEDIR)
- FILE_AREA_BONES = $(FILE_AREA_VAR)
- FILE_AREA_LEVL = $(FILE_AREA_VAR)
--SHELLDIR = $(PREFIX)/local/bin
-+SHELLDIR = $(PREFIX)/usr/bin
-
- # Defs. compatible with Linux's FSSTND 1.2
- # FILE_AREA_VAR = /var/lib/games/slashem
-@@ -69,7 +69,7 @@
- # FILE_AREA_DOC = /usr/share/doc/slashem
- # FILE_AREA_BONES = $(FILE_AREA_VAR)
- # FILE_AREA_LEVL = $(FILE_AREA_VAR)
--# SHELLDIR = /usr/games
-+# SHELLDIR = /usr/bin
-
- # KDEDIR = /opt/kde
- # SHELLDIR = $(KDEDIR)/bin
---- includeconfig.h.bak 2015-07-14 12:10:52.030400467 -0800
-+++ include/config.h 2015-07-14 12:27:13.817033203 -0800
-@@ -231,7 +231,7 @@
- #ifdef UNIX
- /* path and file name extension for compression program */
- # define COMPRESS "/usr/bin/compress" /* Lempel-Ziv compression */
--# define COMPRESS_EXTENSION ".Z" /* compress's extension */
-+# define COMPRESS_EXTENSION ".gz" /* compress's extension */
-
- /* An example of one alternative you might want to use: */
- /* # define COMPRESS "/usr/local/bin/gzip" */ /* FSF gzip compression */
-@@ -249,7 +249,7 @@
- * a tar-like file, thus making a neater installation. See *conf.h
- * for detailed configuration.
- */
--/* #define DLB */ /* not supported on all platforms */
-+#define DLB /* not supported on all platforms */
-
- /*
- * Defining INSURANCE slows down level changes, but allows games that
---- includeunixconf.h.bak 2015-07-14 12:28:20.217030905 -0800
-+++ include/unixconf.h 2015-07-14 13:03:27.956958059 -0800
+--- include/unixconf.h 2015-07-14 18:42:12.480163774 -0800
++++ include/unixconf.h 2015-07-14 18:43:06.113495254 -0800
@@ -38,7 +38,7 @@
#define NETWORK /* if running on a networked system */
/* e.g. Suns sharing a playground through NFS */
@@ -88,8 +18,8 @@
# ifdef TEXTCOLOR
# define VIDEOSHADES
---- srcMakefile.bak 2015-07-14 12:25:08.923704185 -0800
-+++ src/Makefile 2015-07-14 12:25:41.147036404 -0800
+--- src/Makefile 2015-07-14 18:43:18.233494835 -0800
++++ src/Makefile 2015-07-14 18:44:07.770159789 -0800
@@ -124,7 +124,7 @@
# flags for Linux
@@ -119,8 +49,8 @@
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
---- docMakefile.bak 2015-07-14 13:47:17.040200526 -0800
-+++ doc/Makefile 2015-07-14 13:47:31.520200024 -0800
+--- doc/Makefile 2015-07-14 18:44:11.666826314 -0800
++++ doc/Makefile 2015-07-14 18:44:45.236825160 -0800
@@ -53,7 +53,7 @@
# tbl tmac.n Guidebook.mn | groff -Wall -Tdvi > Guidebook.dvi
@@ -130,3 +60,70 @@
MANEXT = 6
FRMANDIR= $(MANDIR:man6=fr/man6)
+--- include/config.h 2015-07-14 18:44:52.163491599 -0800
++++ include/config.h 2015-07-14 18:45:28.396823664 -0800
+@@ -230,8 +230,8 @@
+
+ #ifdef UNIX
+ /* path and file name extension for compression program */
+-# define COMPRESS "/usr/bin/compress" /* Lempel-Ziv compression */
+-# define COMPRESS_EXTENSION ".Z" /* compress's extension */
++# define COMPRESS "/usr/bin/gzip" /* Lempel-Ziv compression */
++# define COMPRESS_EXTENSION ".gz" /* compress's extension */
+
+ /* An example of one alternative you might want to use: */
+ /* # define COMPRESS "/usr/local/bin/gzip" */ /* FSF gzip compression */
+@@ -249,7 +249,7 @@
+ * a tar-like file, thus making a neater installation. See *conf.h
+ * for detailed configuration.
+ */
+-/* #define DLB */ /* not supported on all platforms */
++#define DLB /* not supported on all platforms */
+
+ /*
+ * Defining INSURANCE slows down level changes, but allows games that
+--- Makefile 2015-07-14 18:45:32.823490183 -0800
++++ Makefile 2015-07-14 18:47:19.740153153 -0800
+@@ -17,17 +17,17 @@
+ PREFIX = /usr
+ GAME = slashem
+ # GAME = slashem.prg
+-GAMEUID = games
+-GAMEGRP = bin
++GAMEUID = root
++GAMEGRP = games
+
+ # Permissions - some places use setgid instead of setuid, for instance
+ # See also the option "SECURE" in include/config.h
+-GAMEPERM = 04755
+-FILEPERM = 0644
++GAMEPERM = 02755
++FILEPERM = 0664
+ EXEPERM = 0755
+-DIRPERM = 0755
+-VARFILEPERM = 0644
+-VARDIRPERM = 0755
++DIRPERM = 0775
++VARFILEPERM = 0664
++VARDIRPERM = 0775
+
+ # GAMEDIR also appears in config.h as "HACKDIR".
+ # VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
+@@ -40,7 +40,7 @@
+ # These must agree with the definitions in unixconf.h
+
+ # Defs. for non file areas support.
+-GAMEDIR = $(PREFIX)/local/slashemdir
++GAMEDIR = $(PREFIX)/var/games/slashem
+ VARDIR = $(GAMEDIR)
+ FILE_AREA_VAR = $(VARDIR)
+ FILE_AREA_SAVE = $(VARDIR)/save
+@@ -49,7 +49,7 @@
+ FILE_AREA_DOC = $(GAMEDIR)
+ FILE_AREA_BONES = $(FILE_AREA_VAR)
+ FILE_AREA_LEVL = $(FILE_AREA_VAR)
+-SHELLDIR = $(PREFIX)/local/bin
++SHELLDIR = $(PREFIX)/usr/bin
+
+ # Defs. compatible with Linux's FSSTND 1.2
+ # FILE_AREA_VAR = /var/lib/games/slashem