summarylogtreecommitdiffstats
path: root/spuce-qt-workaround.diff
diff options
context:
space:
mode:
Diffstat (limited to 'spuce-qt-workaround.diff')
-rw-r--r--spuce-qt-workaround.diff20
1 files changed, 20 insertions, 0 deletions
diff --git a/spuce-qt-workaround.diff b/spuce-qt-workaround.diff
new file mode 100644
index 000000000000..1a575f538f31
--- /dev/null
+++ b/spuce-qt-workaround.diff
@@ -0,0 +1,20 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5a1fe0a..6ce4b17 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,10 +28,11 @@ SET(SPUCE_SOVER "${SPUCE_LIBVER}")
+ set(SPUCE_VERSION "${SPUCE_LIBVER}")
+
+ add_subdirectory(spuce)
+-FIND_PACKAGE(Qt5 COMPONENTS Gui Core Widgets)
+-if (NOT Qt5_FOUND)
+- message(STATUS "QT5 not found - will skip building QT5 Apps")
+-endif()
++#FIND_PACKAGE(Qt5 COMPONENTS Gui Core Widgets)
++#if (NOT Qt5_FOUND)
++# message(STATUS "QT5 not found - will skip building QT5 Apps")
++#endif()
++SET(Qt5_FOUND FALSE)
+ cmake_dependent_option(ENABLE_GUI "Enable QT application" ON "Qt5_FOUND" OFF)
+ add_feature_info(ENABLE_GUI ENABLE_GUI "This enables the QT applications to be built")
+ if (ENABLE_GUI)