summarylogtreecommitdiffstats
path: root/submodule_commits.sh
diff options
context:
space:
mode:
Diffstat (limited to 'submodule_commits.sh')
-rwxr-xr-xsubmodule_commits.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/submodule_commits.sh b/submodule_commits.sh
new file mode 100755
index 000000000000..fb45cccf6f59
--- /dev/null
+++ b/submodule_commits.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+# Generate submodule commit hashes
+# This is just for PKGBUILD maintenance and is not supposed to be packaged.
+source PKGBUILD
+submodules="$(printf "|%s" "${_submodules[@]}")"
+curl -s https://api.github.com/repos/VCVRack/Rack/contents/dep?ref=v$pkgver | \
+ jq -r '[.[] | select(.name | test("'"${submodules:1}"'"))] | ("_submodules=(" + ([.[].name] | join(" ")) + ")", "_commits=(" + ([.[].sha[:7]] | join(" ")) + ")")'