summarylogtreecommitdiffstats
path: root/sundials4.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sundials4.patch')
-rw-r--r--sundials4.patch9
1 files changed, 9 insertions, 0 deletions
diff --git a/sundials4.patch b/sundials4.patch
index 2728d2a230dc..754bde37026f 100644
--- a/sundials4.patch
+++ b/sundials4.patch
@@ -11,6 +11,15 @@ Index: setup.py
else:
ext_list[-1].libraries = ["sundials_cvodes", "sundials_nvecserial", "sundials_idas"]
if self.sundials_with_superlu and self.with_SLU: #If SUNDIALS is compiled with support for SuperLU
+@@ -444,7 +444,7 @@
+ compile_time_env=compile_time_env, force=True)
+ ext_list[-1].include_dirs = [np.get_include(), "assimulo","assimulo"+os.sep+"lib", self.incdirs]
+ ext_list[-1].library_dirs = [self.libdirs]
+- ext_list[-1].libraries = ["sundials_kinsol", "sundials_nvecserial"]
++ ext_list[-1].libraries = ["sundials_kinsol", "sundials_nvecserial", "sundials_cvodes", "sundials_idas"]
+
+ if self.sundials_with_superlu and self.with_SLU: #If SUNDIALS is compiled with support for SuperLU
+ ext_list[-1].include_dirs.append(self.SLUincdir)
Index: src/lib/sundials_includes.pxd
===================================================================
--- src/lib/sundials_includes.pxd (revision 875)