summarylogtreecommitdiffstats
path: root/suppress_jinja2_version_check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'suppress_jinja2_version_check.patch')
-rw-r--r--suppress_jinja2_version_check.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/suppress_jinja2_version_check.patch b/suppress_jinja2_version_check.patch
new file mode 100644
index 000000000000..a982bb71210d
--- /dev/null
+++ b/suppress_jinja2_version_check.patch
@@ -0,0 +1,17 @@
+diff -rupN pyload/module/setup.py pyloadp/module/setup.py
+--- pyload/module/setup.py 2012-10-13 10:31:30.000000000 +0200
++++ pyloadp/module/setup.py 2014-06-12 18:17:30.351347907 +0200
+@@ -242,13 +242,6 @@ class Setup():
+ import jinja2
+
+ v = jinja2.__version__
+- if v and "unknown" not in v:
+- if not v.startswith("2.5") and not v.startswith("2.6"):
+- print _("Your installed jinja2 version %s seems too old.") % jinja2.__version__
+- print _("You can safely continue but if the webinterface is not working,")
+- print _("please upgrade or deinstall it, pyLoad includes a sufficient jinja2 libary.")
+- print
+- jinja = False
+ except:
+ pass
+