summarylogtreecommitdiffstats
path: root/system-libuv.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system-libuv.patch')
-rw-r--r--system-libuv.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/system-libuv.patch b/system-libuv.patch
new file mode 100644
index 000000000000..d5ab8798cc7d
--- /dev/null
+++ b/system-libuv.patch
@@ -0,0 +1,27 @@
+diff --git a/setup.py b/setup.py
+index fe276b8..2f0f269 100644
+--- a/setup.py
++++ b/setup.py
+@@ -6,7 +6,6 @@ try:
+ from setuptools import setup, Extension
+ except ImportError:
+ from distutils.core import setup, Extension
+-from setup_libuv import libuv_build_ext, libuv_sdist
+
+
+ __version__ = "1.0.0"
+@@ -32,12 +31,11 @@ setup(name = "pyuv",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4"
+ ],
+- cmdclass = {'build_ext': libuv_build_ext,
+- 'sdist' : libuv_sdist},
+ ext_modules = [Extension('pyuv',
+ sources = ['src/pyuv.c'],
++ libraries = ['uv'],
+ define_macros=[('MODULE_VERSION', __version__),
+- ('LIBUV_REVISION', libuv_build_ext.libuv_revision)]
++ ('LIBUV_REVISION', '0')]
+ )]
+ )
+