summarylogtreecommitdiffstats
path: root/test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'test.sh')
-rwxr-xr-xtest.sh28
1 files changed, 28 insertions, 0 deletions
diff --git a/test.sh b/test.sh
new file mode 100755
index 000000000000..64ea7823762f
--- /dev/null
+++ b/test.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+set -eu
+
+source ./PKGBUILD
+
+echo "## install start"
+pacman -U --noconfirm ${pkgname}-${pkgver}-${pkgrel}-x86_64.pkg.tar.xz
+
+echo "## install complete"
+
+echo "## check installed files"
+
+cfn-guard --help
+
+echo "## check bash completion"
+ls -l /usr/share/bash-completion/completions/cfn-guard
+head /usr/share/bash-completion/completions/cfn-guard
+
+echo "## check zsh completion"
+ls -l /usr/share/zsh/site-functions/_cfn-guard
+head /usr/share/zsh/site-functions/_cfn-guard
+
+echo "## check fish completion"
+ls -l /usr/share/fish/completions/cfn-guard.fish
+head /usr/share/fish/completions/cfn-guard.fish
+
+echo "test OK"