summarylogtreecommitdiffstats
path: root/tvtime-1.0.2-libsupc++.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tvtime-1.0.2-libsupc++.patch')
-rw-r--r--tvtime-1.0.2-libsupc++.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/tvtime-1.0.2-libsupc++.patch b/tvtime-1.0.2-libsupc++.patch
new file mode 100644
index 000000000000..cc76d2decc62
--- /dev/null
+++ b/tvtime-1.0.2-libsupc++.patch
@@ -0,0 +1,16 @@
+Link to libsupc++ instead of bringing in libstdc++ just because tomsocomp
+is written in C++. It does not use STL so it needs not the whole standard
+library.
+Index: tvtime-1.0.2/src/Makefile.am
+===================================================================
+--- tvtime-1.0.2.orig/src/Makefile.am
++++ tvtime-1.0.2/src/Makefile.am
+@@ -77,7 +77,7 @@ tvtime_CFLAGS = $(TTF_CFLAGS) $(PNG_CFLA
+ $(PLUGIN_CFLAGS) $(X11_CFLAGS) $(XML2_FLAG) \
+ $(FONT_CFLAGS) $(AM_CFLAGS)
+ tvtime_LDFLAGS = $(TTF_LIBS) $(ZLIB_LIBS) $(PNG_LIBS) \
+- $(X11_LIBS) $(XML2_LIBS) -lm -lstdc++
++ $(X11_LIBS) $(XML2_LIBS) -lm -lsupc++
+
+ tvtime_command_SOURCES = utils.h utils.c tvtimeconf.h tvtimeconf.c \
+ tvtime-command.c