summarylogtreecommitdiffstats
path: root/update.md
diff options
context:
space:
mode:
Diffstat (limited to 'update.md')
-rw-r--r--update.md26
1 files changed, 26 insertions, 0 deletions
diff --git a/update.md b/update.md
new file mode 100644
index 000000000000..261227751d80
--- /dev/null
+++ b/update.md
@@ -0,0 +1,26 @@
+1. edit `PKGBUILD` file
+update the version number `pkgver=`
+
+2. update integrity checksum
+```
+$ makepkg -g
+```
+copy the output and paste it in `PKGBUILD` file, eg.
+```
+md5sums=('output')
+```
+source: https://wiki.archlinux.org/index.php/PKGBUILD#Integrity
+
+3. sanity check
+```
+$ namcap PKGBUILD
+$ makepkg
+$ namcap <package_name>.pkg.tar.xz
+```
+source: https://wiki.archlinux.org/index.php/Creating_packages#Checking_package_sanity
+
+4. generate `.SRCINFO`
+```
+$ makepkg --printsrcinfo > .SRCINFO
+```
+source: https://wiki.archlinux.org/index.php/.SRCINFO