summarylogtreecommitdiffstats
path: root/update.rb
diff options
context:
space:
mode:
Diffstat (limited to 'update.rb')
-rw-r--r--update.rb6
1 files changed, 4 insertions, 2 deletions
diff --git a/update.rb b/update.rb
index bdaac6f4c29b..4df701a584f2 100644
--- a/update.rb
+++ b/update.rb
@@ -13,11 +13,13 @@ artifact = Mixlib::Install.new(options).artifact_info
pkgbuild = File.read("PKGBUILD")
pkgbuild.split("\n").each do |line|
if line =~ /pkgver=(.*)/
- puts "#{$1} → #{artifact.version}"
if $1 == artifact.version
- puts "This version is already current!"
+ puts "#{$1}: This version is already current!"
exit 1
end
+ File.open(".commit_msg", "w") do |f|
+ f.write("#{$1} → #{artifact.version}")
+ end
break
end
end