summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh14
1 files changed, 14 insertions, 0 deletions
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..383ad354dddb
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,14 @@
+#!/usr/bin/env bash
+
+#
+# This script is used to semi-automatically run a build and update the PKGBUILD file locally.
+# It is not used in the AUR builds in any way, and is only for manual releasing purposes.
+#
+
+set -e
+
+rm -rf libreswan-*.pkg.tar.zst
+makepkg
+makepkg --printsrcinfo > .SRCINFO
+newversion=$(grep pkgver .SRCINFO | awk -F= '{print $2}' | sed -e 's/ //g')
+git commit -am "Updated to ${newversion}."