summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/update.sh b/update.sh
index 3498fcad693e..2ee574922e6b 100755
--- a/update.sh
+++ b/update.sh
@@ -1,6 +1,6 @@
#!/bin/bash
-ver=$(pacman -Ss linux | sed -rn 's/^core\/linux ([0-9]+(\.[0-9]+)*\.arch[0-9]+).* \[installed\]/\1/p')
+ver=$(pacman -Qs linux | grep "local/linux " | sed -rn 's/^local\/linux ([0-9]+(\.[0-9]+)*\.arch[0-9]+).*/\1/p')
sed -i "s/pkgver=.*$/pkgver=$ver/" PKGBUILD
updpkgsums
makepkg --printsrcinfo > .SRCINFO