summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/update.sh b/update.sh
index 17f406e252b7..a72f55aa5b5f 100755
--- a/update.sh
+++ b/update.sh
@@ -5,7 +5,7 @@ SELF_DIR="$(dirname "${BASH_SOURCE[0]}")"
source "${SELF_DIR}/PKGBUILD"
echo "Current version: ${pkgver}"
echo -n "Checking latest version... "
-LATEST_VER="$(curl -si https://github.com/lyswhut/lx-music-desktop/releases/latest | sed -nr 's@^location:.*/v(\w*)@\1@p')"
+LATEST_VER="$(curl -si https://github.com/lyswhut/lx-music-desktop/releases/latest | sed -nr 's@^location:.*/v([[:alnum:]\.]+)\r?@\1@p')"
echo "${LATEST_VER}"
if [ "${LATEST_VER}" = ${pkgver} ]; then