summarylogtreecommitdiffstats
path: root/update.sh
diff options
context:
space:
mode:
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh9
1 files changed, 6 insertions, 3 deletions
diff --git a/update.sh b/update.sh
index 458e1fd1e168..a41c5438459e 100755
--- a/update.sh
+++ b/update.sh
@@ -32,13 +32,16 @@ if [[ $# == 2 ]]; then
pkgrel=$2
fi
+# Manually download the logo build artifact to avoid the fact that the GitLab
+# artifacts download using the tag may give you an incorrect version of the
+# logo build artifacts.
+wget -O logo.zip "https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v$1/download?job=build_logo"
+
SRCS=(
https://files.pythonhosted.org/packages/source/${PROJ_NAME:0:1}/${PROJ_NAME}/${PROJ_NAME}-$1.tar.gz
- https://gitlab.com/sumner/sublime-music/-/jobs/artifacts/v$1/download?job=build_logo
+ logo.zip
)
-rm -rf 'download?job=build_logo'
-
printf '' > PKGBUILD
echo "# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>