summarylogtreecommitdiffstats
path: root/update2.sh
diff options
context:
space:
mode:
Diffstat (limited to 'update2.sh')
-rwxr-xr-xupdate2.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/update2.sh b/update2.sh
index cd8aa64cf21d..8d6b01e2f464 100755
--- a/update2.sh
+++ b/update2.sh
@@ -2,7 +2,7 @@
set -eo pipefail +H
-DEB_REPO=http://repos.tixeo.com/debian
+DEB_REPO=https://repos.tixeo.com/debian
SUITE=bullseye
COMPONENT=non-free
ARCH=amd64
@@ -15,7 +15,7 @@ built_ver=`grep ^pkgver= PKGBUILD | cut -d= -f2`
t_packages=`mktemp`
trap 'rm -f $t_packages' EXIT
-curl -s $DEB_REPO/dists/$SUITE/$COMPONENT/binary-$ARCH/Packages | sed -n -e "/^Package: $PACKAGE$/,/^$/{/^$/!p}" > $t_packages
+curl -Ls $DEB_REPO/dists/$SUITE/$COMPONENT/binary-$ARCH/Packages | sed -n -e "/^Package: $PACKAGE$/,/^$/{/^$/!p}" > $t_packages
upstream_ver=`grep "^Version:" $t_packages | sed -e 's/\w\+: //'`