summarylogtreecommitdiffstats
path: root/updates.sh
diff options
context:
space:
mode:
Diffstat (limited to 'updates.sh')
-rwxr-xr-xupdates.sh18
1 files changed, 18 insertions, 0 deletions
diff --git a/updates.sh b/updates.sh
new file mode 100755
index 000000000000..f2e72b8b9111
--- /dev/null
+++ b/updates.sh
@@ -0,0 +1,18 @@
+#!/bin/bash
+source PKGBUILD
+_version=$(git ls-remote --tags --refs --sort="version:refname" ${url}.git | tail -n1)
+_version=${_version##*/}
+_version=${_version%%-*}
+_version=${_version//v/}
+echo ${_version}
+echo "updating checksums and version for PKGBUILDs"
+sed -i "s/^pkgver=.*/pkgver='${_version}'/" PKGBUILD
+updpkgsums
+echo "creating .SRCINFO"
+makepkg --printsrcinfo > .SRCINFO
+#sha256sum skywire-scripts.tar.gz
+echo "don't forget to increment pkgrel if you edited the PKGBUILD"
+source PKGBUILD && echo "pkgver=${pkgver}" && echo "pkgrel=${pkgrel}"
+echo
+echo "git add -f PKGBUILD .SRCINFO updates.sh"
+echo 'git commit -m " "'