summarylogtreecommitdiffstats
path: root/usd_python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'usd_python.patch')
-rw-r--r--usd_python.patch31
1 files changed, 16 insertions, 15 deletions
diff --git a/usd_python.patch b/usd_python.patch
index 8cf7e8fcbbd4..f7cd0305b14a 100644
--- a/usd_python.patch
+++ b/usd_python.patch
@@ -1,26 +1,27 @@
diff --git a/build_files/cmake/platform/platform_unix.cmake b/build_files/cmake/platform/platform_unix.cmake
-index ac570f17e47..505aa97934c 100644
+index bdf39d04d32..4322e0aa042 100644
--- a/build_files/cmake/platform/platform_unix.cmake
+++ b/build_files/cmake/platform/platform_unix.cmake
-@@ -320,6 +320,9 @@ if(WITH_BOOST)
- if(WITH_OPENVDB)
- list(APPEND __boost_packages iostreams)
- endif()
-+ if(WITH_USD)
-+ list(APPEND __boost_packages python)
-+ endif()
- list(APPEND __boost_packages system)
- find_package(Boost 1.48 COMPONENTS ${__boost_packages})
- if(NOT Boost_FOUND)
-diff --git a/source/blender/usd/CMakeLists.txt b/source/blender/usd/CMakeLists.txt
-index 6ea02f44d76..0ec18e17689 100644
+@@ -334,6 +334,10 @@ if(WITH_OPENVDB)
+ endif()
+ endif()
+
++if(WITH_USD)
++ list(APPEND __boost_packages python)
++endif()
++
+ if(WITH_NANOVDB)
+ find_package_wrapper(NanoVDB)
+ set_and_warn_library_found("NanoVDB" NANOVDB_FOUND WITH_NANOVDB)
+diff --git a/source/blender/io/usd/CMakeLists.txt b/source/blender/io/usd/CMakeLists.txt
+index ebd292782c0..02486e72461 100644
--- a/source/blender/io/usd/CMakeLists.txt
+++ b/source/blender/io/usd/CMakeLists.txt
-@@ -48,6 +48,7 @@ set(INC
+@@ -55,6 +55,7 @@ set(INC
set(INC_SYS
${USD_INCLUDE_DIRS}
${BOOST_INCLUDE_DIR}
+ ${PYTHON_INCLUDE_DIRS}
${TBB_INCLUDE_DIR}
+ ${PYTHON_INCLUDE_DIR}
)
-