summarylogtreecommitdiffstats
path: root/use-lua53.patch
diff options
context:
space:
mode:
Diffstat (limited to 'use-lua53.patch')
-rw-r--r--use-lua53.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/use-lua53.patch b/use-lua53.patch
new file mode 100644
index 000000000000..aaad484be5c4
--- /dev/null
+++ b/use-lua53.patch
@@ -0,0 +1,15 @@
+diff --unified --recursive --text lsyncd-2.3.1.orig/CMakeLists.txt lsyncd-2.3.1/CMakeLists.txt
+--- lsyncd-2.3.1.orig/CMakeLists.txt 2023-04-16 01:22:15.765411996 +0200
++++ lsyncd-2.3.1/CMakeLists.txt 2023-04-16 01:22:36.962131402 +0200
+@@ -12,7 +12,10 @@
+
+
+ # finding Lua
+-find_package( Lua REQUIRED )
++set(LUA_INCLUDE_DIR /usr/include/lua5.3)
++set(LUA_EXECUTABLE /usr/bin/lua5.3)
++set(LUA_COMPILER /usr/bin/luac5.3)
++set(LUA_LIBRARIES /usr/lib/liblua5.3.so)
+ include_directories ( ${LUA_INCLUDE_DIR} )
+
+