summarylogtreecommitdiffstats
path: root/use-static-llvm40.patch
diff options
context:
space:
mode:
Diffstat (limited to 'use-static-llvm40.patch')
-rw-r--r--use-static-llvm40.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/use-static-llvm40.patch b/use-static-llvm40.patch
new file mode 100644
index 000000000000..00c734171fa0
--- /dev/null
+++ b/use-static-llvm40.patch
@@ -0,0 +1,54 @@
+diff -aur --no-dereference radium-5.8.9.pristine/bin/packages/faust2/compiler/Makefile.unix radium-5.8.9.new/bin/packages/faust2/compiler/Makefile.unix
+--- radium-5.8.9.pristine/bin/packages/faust2/compiler/Makefile.unix 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/bin/packages/faust2/compiler/Makefile.unix 2018-09-15 08:12:35.291841616 +0100
+@@ -26,7 +26,7 @@
+ # link a suitable llvm-config to a location somewhere on your PATH, or just
+ # set LLVM_CONFIG manually.
+
+-LLVM_CONFIG = $(lastword $(wildcard /usr/bin/llvm-config* /opt/local/bin/llvm-config* /usr/local/bin/llvm-config*) $(shell which llvm-config 2> /dev/null))
++LLVM_CONFIG = /usr/bin/llvm-config-4.0
+
+ ## On Darwin build both 32 and 64-bits intel versions
+ ifeq ($(system), Darwin)
+@@ -47,7 +47,7 @@
+ endif
+ endif
+
+-LLVM_STATIC_LIBS = $(shell $(LLVM_CONFIG) --libfiles)
++LLVM_STATIC_LIBS = $(shell $(LLVM_CONFIG) --link-static --libfiles)
+ LLVM_VERSION = $(shell $(LLVM_CONFIG) --version)
+
+ ## On Windows (mingw32) we must link against the socket library.
+@@ -225,7 +225,7 @@
+ ifneq ($(findstring MINGW32, $(system)),)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o `$(LLVM_CONFIG) --ldflags` $(LLVMLIBS) $(CLANGLIBS) $(LIBS) -lpthread -o faust
+ else
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o `$(LLVM_CONFIG) --ldflags` $(LLVMLIBS) $(CLANGLIBS) -ldl -lcrypto -lz -lncurses -lpthread -o faust
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o $(LLVM_STATIC_LIBS) $(CLANGLIBS) -ldl -lcrypto -lz -lncurses -lpthread -o faust
+ endif
+
+ ifeq ($(system), Darwin)
+diff -aur --no-dereference radium-5.8.9.pristine/build_linux_common.sh radium-5.8.9.new/build_linux_common.sh
+--- radium-5.8.9.pristine/build_linux_common.sh 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/build_linux_common.sh 2018-09-15 08:12:35.291841616 +0100
+@@ -106,17 +106,11 @@
+ PYTHONLIBPATH=`$PYTHONEXE -c "import sys;print '-L'+sys.prefix+'/lib'"`
+ PYTHONLIBNAME=`$PYTHONEXE -c "import sys;print '-lpython'+sys.version[:3]"`
+
+-LLVM_OPTS=`llvm-config --cppflags`
+-
+-MAYBELLVM=`llvm-config --libdir`/libLLVM-`llvm-config --version`.so
+-if [ -f $MAYBELLVM ]; then
+- LLVMLIBS=-lLLVM-`llvm-config --version`
+-else
+- LLVMLIBS=`llvm-config --libs`
+-fi
++LLVM_OPTS=`llvm-config-4.0 --cppflags`
++LLVMLIBS=`llvm-config-4.0 --link-static --libfiles`
+
+ if env |grep INCLUDE_FAUSTDEV ; then
+- FAUSTLDFLAGS="bin/packages/QScintilla_gpl-2.10.1/Qt4Qt5/libqscintilla2_qt5.a bin/packages/faust2/compiler/libfaust.a `$PKG --libs uuid` `llvm-config --ldflags` $LLVMLIBS -lcrypto -lncurses"
++ FAUSTLDFLAGS="bin/packages/QScintilla_gpl-2.10.1/Qt4Qt5/libqscintilla2_qt5.a bin/packages/faust2/compiler/libfaust.a `$PKG --libs uuid` $LLVMLIBS -lcrypto -lncurses"
+ else
+ FAUSTLDFLAGS=""
+ fi