summarylogtreecommitdiffstats
path: root/use_system_eigen.patch
diff options
context:
space:
mode:
Diffstat (limited to 'use_system_eigen.patch')
-rw-r--r--use_system_eigen.patch29
1 files changed, 11 insertions, 18 deletions
diff --git a/use_system_eigen.patch b/use_system_eigen.patch
index 6be37efb23ab..0571ecbf1ac4 100644
--- a/use_system_eigen.patch
+++ b/use_system_eigen.patch
@@ -1,20 +1,19 @@
-Only in CVXcanon-0.1.1-orig/build: temp.linux-x86_64-3.6
-diff -aur CVXcanon-0.1.1-orig/setup.py CVXcanon-0.1.1/setup.py
---- CVXcanon-0.1.1-orig/setup.py 2017-01-10 13:39:21.161947185 -0500
-+++ CVXcanon-0.1.1/setup.py 2017-01-10 13:39:54.981932516 -0500
-@@ -7,7 +7,7 @@
+diff -urN CVXcanon-0.1.2-orig/setup.py CVXcanon-0.1.2/setup.py
+--- CVXcanon-0.1.2-orig/setup.py 2020-09-18 14:25:26.000000000 -0400
++++ CVXcanon-0.1.2/setup.py 2021-08-30 03:50:55.922117288 -0400
+@@ -12,7 +12,7 @@
canon = Extension(
'_CVXcanon',
sources=['src/CVXcanon.cpp', 'src/LinOpOperations.cpp', 'src/python/CVXcanon_wrap.cpp'],
-- include_dirs=['src/', 'src/python/', 'include/Eigen', numpy.get_include()]
-+ include_dirs=['src/', 'src/python/', '/usr/include/eigen3', numpy.get_include()]
+- include_dirs=['src/', 'src/python/', 'include/Eigen', get_numpy_include()]
++ include_dirs=['src/', 'src/python/', '/usr/include/eigen3', get_numpy_include()]
)
- base_dir = os.path.dirname(__file__)
-diff -aur CVXcanon-0.1.1-orig/src/Utils.hpp CVXcanon-0.1.1/src/Utils.hpp
---- CVXcanon-0.1.1-orig/src/Utils.hpp 2017-01-10 13:38:30.215304531 -0500
-+++ CVXcanon-0.1.1/src/Utils.hpp 2017-01-10 13:40:18.425256236 -0500
-@@ -15,12 +15,12 @@
+
+diff -urN CVXcanon-0.1.2-orig/src/Utils.hpp CVXcanon-0.1.2/src/Utils.hpp
+--- CVXcanon-0.1.2-orig/src/Utils.hpp 2020-09-18 14:25:26.000000000 -0400
++++ CVXcanon-0.1.2/src/Utils.hpp 2021-08-30 03:51:31.438834630 -0400
+@@ -14,8 +14,8 @@
// Some useful defines for Matricies/etc.
@@ -25,9 +24,3 @@ diff -aur CVXcanon-0.1.1-orig/src/Utils.hpp CVXcanon-0.1.1/src/Utils.hpp
#define NULL_MATRIX Eigen::SparseMatrix<double>(0,0)
- typedef Eigen::Matrix<int, Eigen::Dynamic, 1> Vector;
- typedef Eigen::SparseMatrix<double> Matrix;
- typedef std::map<int, Matrix> CoeffMap;
--typedef Eigen::Triplet<double> Triplet;
-\ No newline at end of file
-+typedef Eigen::Triplet<double> Triplet;