summarylogtreecommitdiffstats
path: root/validity-sensor.patch
diff options
context:
space:
mode:
Diffstat (limited to 'validity-sensor.patch')
-rw-r--r--validity-sensor.patch45
1 files changed, 22 insertions, 23 deletions
diff --git a/validity-sensor.patch b/validity-sensor.patch
index c10bb215dc94..dc48037a057c 100644
--- a/validity-sensor.patch
+++ b/validity-sensor.patch
@@ -1,10 +1,10 @@
diff --git a/configure.ac b/configure.ac
-index 58ea9e9..830e749 100644
+index bc38434..8f39399 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,9 @@ AC_SUBST(lt_age)
- all_drivers="upekts upektc upeksonly vcom5s uru4000 fdu2000 aes1610 aes1660 aes2501 aes2550 aes2660 aes3500 aes4000 vfs101 vfs301 vfs5011 upektc_img etes603 vfs0050"
+ all_drivers="upekts upektc upeksonly vcom5s uru4000 fdu2000 aes1610 aes1660 aes2501 aes2550 aes2660 aes3500 aes4000 vfs101 vfs301 vfs5011 upektc_img etes603 vfs0050 elan"
+# XXX: VCS
+all_drivers="$all_drivers vcs"
@@ -12,9 +12,9 @@ index 58ea9e9..830e749 100644
require_imaging='no'
require_aeslib='no'
require_aesX660='no'
-@@ -50,6 +53,9 @@ enable_upektc_img='no'
- enable_etes603='no'
+@@ -51,6 +54,9 @@ enable_etes603='no'
enable_vfs0050='no'
+ enable_elan='no'
+# XXX: VCS
+enable_vcs='no'
@@ -22,9 +22,9 @@ index 58ea9e9..830e749 100644
AC_ARG_WITH([drivers],[AS_HELP_STRING([--with-drivers],
[List of drivers to enable])],
[drivers="$withval"],
-@@ -155,6 +161,12 @@ for driver in `echo ${drivers} | sed -e 's/,/ /g' -e 's/,$//g'`; do
- AC_DEFINE([ENABLE_VFS0050], [], [Build Validity VFS0050 driver])
- enable_vfs0050="yes"
+@@ -160,6 +166,12 @@ for driver in `echo ${drivers} | sed -e 's/,/ /g' -e 's/,$//g'`; do
+ AC_DEFINE([ENABLE_ELAN], [], [Build Elan driver])
+ enable_elan="yes"
;;
+
+ # XXX: VCS
@@ -35,9 +35,9 @@ index 58ea9e9..830e749 100644
esac
done
-@@ -182,6 +194,9 @@ AM_CONDITIONAL([ENABLE_UPEKTC_IMG], [test "$enable_upektc_img" = "yes"])
- AM_CONDITIONAL([ENABLE_ETES603], [test "$enable_etes603" = "yes"])
+@@ -188,6 +200,9 @@ AM_CONDITIONAL([ENABLE_ETES603], [test "$enable_etes603" = "yes"])
AM_CONDITIONAL([ENABLE_VFS0050], [test "$enable_vfs0050" = "yes"])
+ AM_CONDITIONAL([ENABLE_ELAN], [test "$enable_elan" = "yes"])
+# XXX: VCS
+AM_CONDITIONAL([ENABLE_VCS], [test "$enable_vcs" = "yes"])
@@ -45,9 +45,9 @@ index 58ea9e9..830e749 100644
PKG_CHECK_MODULES(LIBUSB, [libusb-1.0 >= 0.9.1])
AC_SUBST(LIBUSB_CFLAGS)
-@@ -407,6 +422,14 @@ if test x$enable_vfs0050 != xno ; then
+@@ -418,6 +433,14 @@ if test x$enable_elan != xno ; then
else
- AC_MSG_NOTICE([ vfs0050 driver disabled])
+ AC_MSG_NOTICE([ elan driver disabled])
fi
+
+# XXX: VCS
@@ -61,12 +61,12 @@ index 58ea9e9..830e749 100644
AC_MSG_NOTICE([** aeslib helper functions enabled])
else
diff --git a/libfprint/Makefile.am b/libfprint/Makefile.am
-index a7fb162..a473179 100644
+index 6d1e9c6..6ea0b80 100644
--- a/libfprint/Makefile.am
+++ b/libfprint/Makefile.am
-@@ -23,6 +23,11 @@ UPEKTC_IMG_SRC = drivers/upektc_img.c drivers/upektc_img.h
- ETES603_SRC = drivers/etes603.c
+@@ -24,6 +24,11 @@ ETES603_SRC = drivers/etes603.c
VFS0050_SRC = drivers/vfs0050.c drivers/vfs0050.h
+ ELAN_SRC = drivers/elan.c drivers/elan.h
+# XXX: VCS
+VCS_SRCS = drivers/validity/vfsDriver.c \
@@ -76,7 +76,7 @@ index a7fb162..a473179 100644
EXTRA_DIST = \
$(UPEKE2_SRC) \
$(UPEKTS_SRC) \
-@@ -37,6 +42,7 @@ EXTRA_DIST = \
+@@ -38,6 +43,7 @@ EXTRA_DIST = \
$(AES3500_SRC) \
$(AES4000_SRC) \
$(FDU2000_SRC) \
@@ -84,11 +84,10 @@ index a7fb162..a473179 100644
$(VCOM5S_SRC) \
$(VFS101_SRC) \
$(VFS301_SRC) \
-@@ -190,6 +196,12 @@ if ENABLE_VFS0050
- DRIVER_SRC += $(VFS0050_SRC)
+@@ -196,6 +202,11 @@ if ENABLE_ELAN
+ DRIVER_SRC += $(ELAN_SRC)
endif
-+
+# XXX: VCS
+if ENABLE_VCS
+DRIVER_SRC += $(VCS_SRCS)
@@ -98,10 +97,10 @@ index a7fb162..a473179 100644
OTHER_SRC += pixman.c
libfprint_la_CFLAGS += $(IMAGING_CFLAGS)
diff --git a/libfprint/core.c b/libfprint/core.c
-index 8b6fe43..5e28d63 100644
+index 522213e..ac74cbf 100644
--- a/libfprint/core.c
+++ b/libfprint/core.c
-@@ -405,6 +405,11 @@ static struct fp_img_driver * const img_drivers[] = {
+@@ -408,6 +408,11 @@ static struct fp_img_driver * const img_drivers[] = {
&fdu2000_driver,
#endif
*/
@@ -524,7 +523,7 @@ index 0000000..55d1f43
+
+#endif /*vfsWrapper */
diff --git a/libfprint/fp_internal.h b/libfprint/fp_internal.h
-index e309ea9..2310d03 100644
+index 7897a2e..fa9692a 100644
--- a/libfprint/fp_internal.h
+++ b/libfprint/fp_internal.h
@@ -233,6 +233,9 @@ enum fp_print_data_type fpi_driver_get_data_type(struct fp_driver *drv);
@@ -537,8 +536,8 @@ index e309ea9..2310d03 100644
struct fp_img_driver {
struct fp_driver driver;
uint16_t flags;
-@@ -309,6 +312,11 @@ extern struct fp_img_driver etes603_driver;
- extern struct fp_img_driver vfs0050_driver;
+@@ -312,6 +315,11 @@ extern struct fp_img_driver vfs0050_driver;
+ extern struct fp_img_driver elan_driver;
#endif
+/* XXX: VCS */